aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@gentoo.org>2010-02-09 21:20:00 +0100
committerJustin Lecher (jlec) <jlec@gentoo.org>2010-02-09 21:20:13 +0100
commit51c167fbd4ee691a4ddc3fec82ce1ef5d9d5a7c7 (patch)
tree2cede4370730644b2cbece743b7bc35b07b62f6a /app-arch/lbzip2/lbzip2-0.20.ebuild
parentsci-chemistry/votca-csg: fixed as-neeeded bug (diff)
downloadsci-51c167fbd4ee691a4ddc3fec82ce1ef5d9d5a7c7.tar.gz
sci-51c167fbd4ee691a4ddc3fec82ce1ef5d9d5a7c7.tar.bz2
sci-51c167fbd4ee691a4ddc3fec82ce1ef5d9d5a7c7.zip
InCvs
Diffstat (limited to 'app-arch/lbzip2/lbzip2-0.20.ebuild')
-rw-r--r--app-arch/lbzip2/lbzip2-0.20.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-arch/lbzip2/lbzip2-0.20.ebuild b/app-arch/lbzip2/lbzip2-0.20.ebuild
deleted file mode 100644
index eb570ebd5..000000000
--- a/app-arch/lbzip2/lbzip2-0.20.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Pthreads-based parallel bzip2/bunzip2 filter, passable to GNU tar"
-HOMEPAGE="http://lacos.hu/"
-SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="symlink test"
-
-RDEPEND=""
-DEPEND="
- test? (
- app-shells/dash
- sys-process/time
- )"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-Makefile.patch
-}
-
-src_compile() {
- append-lfs-flags
- emake CC=$(tc-getCC) || die "emake failed"
-}
-
-src_test() {
- if [ -t 0 ] || return; then
- rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
- hexdump -n 10485760 /dev/urandom > "${T}/rnd"
- emake -j1 SHELL=/bin/dash PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
- || die "make check failed"
- else
- ewarn "make check must be run attached to a terminal"
- fi
-}
-
-src_install() {
- dobin ${PN} || die "Installation of ${PN} failed"
- dodoc ChangeLog README || die "no docs"
- doman ${PN}.1 || die "no man"
- insinto "/usr/share/${PN}"
- doins corr-perf.sh malloc_trace.pl || die
-
- if use symlink; then
- dosym /usr/bin/${PN} /usr/bin/gzip || die
- dosym /usr/bin/un${PN} /usr/bin/gunzip || die
- fi
-}