aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Arteaga <andyspiros@gmail.com>2012-02-28 23:28:18 +0100
committerAndrea Arteaga <andyspiros@gmail.com>2012-02-28 23:28:18 +0100
commit567eecceff67dc77750b9c1782a2143ae1fdaf79 (patch)
tree8e2d42252fd62c48b2b1031ca0f2f7149b30bc2e /app-benchmarks
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci; github.c... (diff)
downloadsci-567eecceff67dc77750b9c1782a2143ae1fdaf79.tar.gz
sci-567eecceff67dc77750b9c1782a2143ae1fdaf79.tar.bz2
sci-567eecceff67dc77750b9c1782a2143ae1fdaf79.zip
[app-benchmarks/numbench] Version 0.2_beta1.
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/numbench/ChangeLog3
-rw-r--r--app-benchmarks/numbench/Manifest1
-rw-r--r--app-benchmarks/numbench/metadata.xml4
-rw-r--r--app-benchmarks/numbench/numbench-0.2_beta1.ebuild36
4 files changed, 42 insertions, 2 deletions
diff --git a/app-benchmarks/numbench/ChangeLog b/app-benchmarks/numbench/ChangeLog
index 793dfac6e..b3edf67ab 100644
--- a/app-benchmarks/numbench/ChangeLog
+++ b/app-benchmarks/numbench/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 28 Feb 2012; Andrea Arteaga <andyspiros@gmail.com> +numbench-0.2_beta1.ebuild metadata.xml
+ Version 0.2_beta1 added. Metadata updated.
+
06 Sep 2011; Sébastien Fabbro <bicatali@gentoo.org> numbench-9999.ebuild:
Updated eselect dependency
diff --git a/app-benchmarks/numbench/Manifest b/app-benchmarks/numbench/Manifest
new file mode 100644
index 000000000..67613af43
--- /dev/null
+++ b/app-benchmarks/numbench/Manifest
@@ -0,0 +1 @@
+DIST numbench-0.2_beta1.tbz2 28650 SHA256 92cb06290024d3be89f62f68911a13b7df582caa97cd3455d9cf0a1114464f5f SHA512 d36b084c6c4bedfb6e461e734b8449353a1088c40a9ca41b2034751966c7187899557ff0e835c807bd455c41de3bc5b4113335cd6e291b3da8b2e206ca4869d4 WHIRLPOOL c90c1c125ca9999d6b1628b86741780b5570c8f6dbb410a15602c5b00a89f83ba758a7c41c96a7ac9cb96df10d06a90290c0efdd8700b69b9290ff36d4d8402a
diff --git a/app-benchmarks/numbench/metadata.xml b/app-benchmarks/numbench/metadata.xml
index 9a4daeda7..5868b425e 100644
--- a/app-benchmarks/numbench/metadata.xml
+++ b/app-benchmarks/numbench/metadata.xml
@@ -5,7 +5,7 @@
<maintainer>
<email>andyspiros@gmail.com</email>
<name>Andrea Arteaga</name>
- <description>Automated bechmarks of numerical libraries</description>
+ <description>Google Summer of Code 2011 student</description>
</maintainer>
- <longdescription>This package contains a set of scripts and C++ sources developed during the Google Summer of Code 2011 project. It aims to benchmark numerical libraries, and more precisely implementations of the standard BLAS, CBLAS, LAPACK, PBLAS, ScaLAPACK and the library FFTW.</longdescription>
+ <longdescription>This package contains a set of scripts developed during the Google Summer of Code 2011 project. It aims to benchmark numerical libraries, and more precisely implementations of the standard BLAS, CBLAS, LAPACK, PBLAS, ScaLAPACK and the library FFTW.</longdescription>
</pkgmetadata>
diff --git a/app-benchmarks/numbench/numbench-0.2_beta1.ebuild b/app-benchmarks/numbench/numbench-0.2_beta1.ebuild
new file mode 100644
index 000000000..f2afa05e1
--- /dev/null
+++ b/app-benchmarks/numbench/numbench-0.2_beta1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils distutils
+
+DESCRIPTION="Automated benchmarks suite"
+HOMEPAGE="http://soc.dev.gentoo.org/~spiros"
+SRC_URI="${HOMEPAGE}/repository/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="!app-admin/eselect-blas
+ !app-admin/eselect-cblas
+ !app-admin/eselect-lapack
+ >=dev-python/matplotlib-1.0.0
+ =app-admin/eselect-1.3.1-r1
+ app-benchmarks/btl"
+
+src_install() {
+ distutils_src_install
+
+ chmod +x exec.py
+ newbin exec.py numbench
+
+ insinto /usr/share/numbench/samples
+ doins *.in
+
+ doman doc/numbench.1
+}