aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Goncalves Martins (rafaelmartins) <rafael@rafaelmartins.eng.br>2010-07-01 20:37:26 -0300
committerRafael Goncalves Martins (rafaelmartins) <rafael@rafaelmartins.eng.br>2010-07-01 20:37:26 -0300
commit19cc0b23bc5007278003e72fdc0c752f8c10a6f4 (patch)
treef0de09cbe0a6cb7abd9392eaad68fa670926e335 /app-portage/g-octave/g-octave-9999.ebuild
parent[sci-electronics/magic] Version bump with cleanups, also fixing bug 299476 (diff)
downloadsci-19cc0b23bc5007278003e72fdc0c752f8c10a6f4.tar.gz
sci-19cc0b23bc5007278003e72fdc0c752f8c10a6f4.tar.bz2
sci-19cc0b23bc5007278003e72fdc0c752f8c10a6f4.zip
Updated the app-portage/g-octave live ebuild
(Portage version: 2.2_rc67/git/Linux i686) (Signed Manifest commit)
Diffstat (limited to 'app-portage/g-octave/g-octave-9999.ebuild')
-rw-r--r--app-portage/g-octave/g-octave-9999.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/app-portage/g-octave/g-octave-9999.ebuild b/app-portage/g-octave/g-octave-9999.ebuild
index 1ddb4f830..ebab60f83 100644
--- a/app-portage/g-octave/g-octave-9999.ebuild
+++ b/app-portage/g-octave/g-octave-9999.ebuild
@@ -13,15 +13,27 @@ EHG_REPO_URI="http://g-octave.rafaelmartins.eng.br/hg/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="svn test"
CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
DEPEND="${CDEPEND}
>=dev-python/docutils-0.6"
RDEPEND="${CDEPEND}
+ svn? ( dev-python/pysvn )
|| ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
-S="${WORKDIR}/${PN}"
+S="${WORKDIR}/hg"
+
+PYTHON_MODNAME="g_octave"
+
+src_prepare() {
+ distutils_src_prepare
+ if ! use svn; then
+ rm -rf g_octave/svn/ || die 'failed to remove the Subversion stuff.'
+ sed -i -e '/g_octave.svn/d' -e '/pysvn/d' setup.py \
+ || die 'failed to remove the SVN stuff from setup.py'
+ fi
+}
src_install() {
distutils_src_install