aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Goncalves Martins (rafaelmartins) <rafael@rafaelmartins.eng.br>2010-06-30 16:01:45 -0300
committerRafael Goncalves Martins (rafaelmartins) <rafael@rafaelmartins.eng.br>2010-06-30 16:01:45 -0300
commitb86270f05c412f042689d0073c8fd40a7736047a (patch)
tree589e8c6a96a9372829e8da8ec0419630c8d0ebfc /app-portage/g-octave/g-octave-9999.ebuild
parentVersion Bump, EAPI bump, drop patch included upstream (diff)
downloadsci-b86270f05c412f042689d0073c8fd40a7736047a.tar.gz
sci-b86270f05c412f042689d0073c8fd40a7736047a.tar.bz2
sci-b86270f05c412f042689d0073c8fd40a7736047a.zip
added app-portage/g-octave
(Portage version: 2.2_rc67/git/Linux i686) (Signed Manifest commit)
Diffstat (limited to 'app-portage/g-octave/g-octave-9999.ebuild')
-rw-r--r--app-portage/g-octave/g-octave-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/g-octave/g-octave-9999.ebuild b/app-portage/g-octave/g-octave-9999.ebuild
new file mode 100644
index 000000000..fe8c1f73f
--- /dev/null
+++ b/app-portage/g-octave/g-octave-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit distutils mercurial
+
+DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
+HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
+EHG_REPO_URI="http://hg.rafaelmartins.eng.br/g-octave/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
+DEPEND="${CDEPEND}
+ >=dev-python/docutils-0.6"
+RDEPEND="${CDEPEND}
+ || ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ distutils_src_install
+ dohtml ${PN}.html
+ doman ${PN}.1
+}
+
+src_test() {
+ PYTHONPATH=. scripts/run_tests.py || die "test failed."
+}