aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2014-01-03 13:53:10 -0700
committerNicolas Bock <nicolasbock@gmail.com>2014-01-03 13:53:10 -0700
commitc8fe72b116f7eac5f4d89df233530e499004c5e1 (patch)
treebad39910e967ae86882959a4f329f46f4daa3fb5 /app-text/jabref
parentapp-text/jabref: Do not remove unjarlib target yet. (diff)
downloadsci-c8fe72b116f7eac5f4d89df233530e499004c5e1.tar.gz
sci-c8fe72b116f7eac5f4d89df233530e499004c5e1.tar.bz2
sci-c8fe72b116f7eac5f4d89df233530e499004c5e1.zip
app-text/jabref: Remove another bundled lib.
Package-Manager: portage-2.2.7
Diffstat (limited to 'app-text/jabref')
-rw-r--r--app-text/jabref/ChangeLog4
-rw-r--r--app-text/jabref/jabref-2.10_beta2-r1.ebuild4
2 files changed, 7 insertions, 1 deletions
diff --git a/app-text/jabref/ChangeLog b/app-text/jabref/ChangeLog
index 1f1a32c3d..6c32d42c8 100644
--- a/app-text/jabref/ChangeLog
+++ b/app-text/jabref/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Jan 2014; Nicolas Bock <nicolasbock@gentoo.org>
+ jabref-2.10_beta2-r1.ebuild:
+ app-text/jabref: Remove another bundled lib.
+
03 Jan 2014; Nicolas Bock <nicolasbock@gentoo.org> jabref-2.10_beta-r1.ebuild,
jabref-2.10_beta2-r1.ebuild:
app-text/jabref: Do not remove unjarlib target yet. We need to first replace
diff --git a/app-text/jabref/jabref-2.10_beta2-r1.ebuild b/app-text/jabref/jabref-2.10_beta2-r1.ebuild
index e8cd8a123..a786ce7c2 100644
--- a/app-text/jabref/jabref-2.10_beta2-r1.ebuild
+++ b/app-text/jabref/jabref-2.10_beta2-r1.ebuild
@@ -21,6 +21,7 @@ IUSE="doc"
COMMON_DEP="
dev-java/fontbox:1.7
+ dev-java/jempbox:1.7
dev-java/spin:0
"
@@ -37,6 +38,7 @@ S="${WORKDIR}/${PN}-${MY_PV}"
java_prepare() {
# Remove bundled dependencies.
rm lib/fontbox*.jar || die
+ rm lib/jempbox*.jar || die
rm lib/spin.jar || die
# Remove unjarlib target (do this only once we have removed all
@@ -45,7 +47,7 @@ java_prepare() {
}
src_compile() {
- local EXTERNAL_JARS="fontbox-1.7,spin"
+ local EXTERNAL_JARS="fontbox-1.7,jempbox-1.7,spin"
local CLASSPATH="$(java-pkg_getjars --with-dependencies ${EXTERNAL_JARS})"
eant \
-Dgentoo.classpath=${CLASSPATH} \