aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-01 16:19:53 +0100
committerHorea Christian <chr@chymera.eu>2021-01-03 17:46:31 -0500
commit228d47476a187096ef16d3a71565e8a7b50c65d5 (patch)
tree112926f9f108ebb5112609244eb3cda7f10289cc /dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild
parentprofiles/package.mask: unmask jgraphx, fixed (diff)
downloadsci-228d47476a187096ef16d3a71565e8a7b50c65d5.tar.gz
sci-228d47476a187096ef16d3a71565e8a7b50c65d5.tar.bz2
sci-228d47476a187096ef16d3a71565e8a7b50c65d5.zip
dev-java/jeuclid-core: EAPI bump, version bump, add keyword
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/sci/pull/1024
Diffstat (limited to 'dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild')
-rw-r--r--dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild b/dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild
new file mode 100644
index 000000000..81910f356
--- /dev/null
+++ b/dev-java/jeuclid-core/jeuclid-core-3.1.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Core module of MathML rendering solution"
+HOMEPAGE="https://github.com/rototor/jeuclid"
+SRC_URI="https://github.com/rototor/jeuclid/archive/jeuclid-parent-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ dev-java/ant-core:0
+ dev-java/batik:1.9
+ dev-java/commons-logging:0
+ dev-java/jcip-annotations:0
+ dev-java/jsr305:0
+ dev-java/xml-commons-external:1.3
+ dev-java/xmlgraphics-commons:2
+"
+
+RDEPEND=">=virtual/jre-1.7
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.7
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/jeuclid-jeuclid-parent-${PV}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-freehep.patch
+)
+
+src_prepare() {
+ default
+
+ # create directory for dependencies
+ mkdir lib && cd lib || die
+
+ # add dependencies into the lib dir
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from batik-1.9 batik-all.jar
+ java-pkg_jar-from commons-logging,jcip-annotations,xml-commons-external-1.3
+ java-pkg_jar-from xml-commons-external-1.3,xmlgraphics-commons-2
+ java-pkg_jar-from jsr305
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+}