aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2014-04-22 19:39:00 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2014-04-22 19:46:37 -0400
commitf4a45f2e7042cfbe62d7dfcb9f3588640affee09 (patch)
tree91df52d7b942012da466f42394b7af292356a63a /dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild
parentdev-java/jlatexmath: version bump (diff)
downloadsci-f4a45f2e7042cfbe62d7dfcb9f3588640affee09.tar.gz
sci-f4a45f2e7042cfbe62d7dfcb9f3588640affee09.tar.bz2
sci-f4a45f2e7042cfbe62d7dfcb9f3588640affee09.zip
dev-java/jlatexmath-fop: version bump
Package-Manager: portage-2.2.10
Diffstat (limited to 'dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild')
-rw-r--r--dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild b/dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild
new file mode 100644
index 000000000..569ceec29
--- /dev/null
+++ b/dev-java/jlatexmath-fop/jlatexmath-fop-1.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+JAVA_PKG_IUSE="examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="jlatexmath plugin for dev-java/fop"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/jlatexmath:1
+ dev-java/xmlgraphics-commons:1.5
+ >=dev-java/fop-0.9.5:0"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="buildJar"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fixpaths.patch"
+ cp "${FILESDIR}/version.xml" "${S}" || die
+ echo "fop.jar=$(java-pkg_getjar fop fop.jar)
+xmlgraphics-commons.jar=$(java-pkg_getjar xmlgraphics-commons-1.5 xmlgraphics-commons.jar)
+jlatexmath.jar=$(java-pkg_getjar jlatexmath-1 jlatexmath.jar)" \
+ >>fop.properties || die
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use source && java-pkg_dosrc src/org
+ use examples && java-pkg_doexamples examples
+}