aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2010-09-30 22:46:40 +0200
committerThomas Kahle <tom111@gmx.de>2010-09-30 22:47:38 +0200
commit78a1af0955747be102e4ed776f14077fd0f5c1e1 (patch)
treeb25be8ee2402ff8d937efc95980c5175ee30b468 /dev-java/jlatexmath/jlatexmath-0.9.3.ebuild
parentpyglet now in main tree (diff)
downloadsci-78a1af0955747be102e4ed776f14077fd0f5c1e1.tar.gz
sci-78a1af0955747be102e4ed776f14077fd0f5c1e1.tar.bz2
sci-78a1af0955747be102e4ed776f14077fd0f5c1e1.zip
dev-java/jlatexmath bump due to Dmitry S. Kulyabov in bug #301048
Diffstat (limited to 'dev-java/jlatexmath/jlatexmath-0.9.3.ebuild')
-rw-r--r--dev-java/jlatexmath/jlatexmath-0.9.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/jlatexmath-0.9.3.ebuild b/dev-java/jlatexmath/jlatexmath-0.9.3.ebuild
new file mode 100644
index 000000000..e6c3efef7
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-0.9.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/index.php/p/jlatexmath/downloads/136/get/ -> jlatexmath-src-all-${PV}.jar"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+}