aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-14 23:30:17 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-14 23:30:17 +0100
commit922447c6e66e945c72d954c5c789b83dc984671e (patch)
tree986f3a6a06013a618f78865167b4037eda08815c /dev-java/jlatexmath/jlatexmath-0.9.7.ebuild
parentdev-java/jeuclid-core: Version bump (diff)
downloadsci-922447c6e66e945c72d954c5c789b83dc984671e.tar.gz
sci-922447c6e66e945c72d954c5c789b83dc984671e.tar.bz2
sci-922447c6e66e945c72d954c5c789b83dc984671e.zip
dev-java/jlatexmath: Version bump
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-java/jlatexmath/jlatexmath-0.9.7.ebuild')
-rw-r--r--dev-java/jlatexmath/jlatexmath-0.9.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/jlatexmath-0.9.7.ebuild b/dev-java/jlatexmath/jlatexmath-0.9.7.ebuild
new file mode 100644
index 000000000..8a4aea21f
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-0.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+ if use examples; then
+ eant examples
+ java-pkg_doexamples examples
+ fi
+}