aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2012-06-22 01:37:10 -0400
committerW. Trevor King <wking@tremily.us>2012-06-22 02:01:32 -0400
commit8b32fdb1c9729aa75875c6960032278df5629d5b (patch)
tree479c32708e4f09c9c29877933c27576bf3004f3c /dev-java
parentdev-java/hdf-java-2.8: explicitly build packages for hdfview (diff)
downloadsci-8b32fdb1c9729aa75875c6960032278df5629d5b.tar.gz
sci-8b32fdb1c9729aa75875c6960032278df5629d5b.tar.bz2
sci-8b32fdb1c9729aa75875c6960032278df5629d5b.zip
dev-java/hdf-java-2.8: fix hdfview script (quotes and sh-bang)
Add a sh-bang to the beginning of the script, because the user may not be using a POSIX shell. Remove redundant, escaped quotes around the java.library.path command substitution. With the quotes, the process uses a garbled Java path, and you see errors like: java.lang.UnsatisfiedLinkError: no jhdf5 in java.library.path
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/hdf-java/hdf-java-2.8.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-java/hdf-java/hdf-java-2.8.ebuild b/dev-java/hdf-java/hdf-java-2.8.ebuild
index e81ff3a65..98c9248f2 100644
--- a/dev-java/hdf-java/hdf-java-2.8.ebuild
+++ b/dev-java/hdf-java/hdf-java-2.8.ebuild
@@ -100,10 +100,11 @@ src_install() {
java-pkg_dojar lib/ext/fitsobj.jar
java-pkg_dojar lib/jhdfview.jar
cat <<-EOF > hdfview
+ #!/bin/sh
export CLASSPATH=\$(java-config --classpath hdf-java)
\$(java-config --java) \
-Xmx1000m \
- -Djava.library.path=\"\$(java-config --library hdf-java)\" \
+ -Djava.library.path=\$(java-config --library hdf-java) \
ncsa.hdf.view.HDFView \
-root "${EROOT}" \$*
EOF