aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-15 00:48:01 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-15 00:48:01 +0100
commitbd37b27ff77800bbc148f60ecce2d0f10361b2fc (patch)
tree82253c8f76cafb018a55f7b63ab63d776dab73c0 /dev-java
parentdev-java/gluegen: import from the java overlay (diff)
downloadsci-bd37b27ff77800bbc148f60ecce2d0f10361b2fc.tar.gz
sci-bd37b27ff77800bbc148f60ecce2d0f10361b2fc.tar.bz2
sci-bd37b27ff77800bbc148f60ecce2d0f10361b2fc.zip
dev-java/jcip-annotations: import from the java overlay
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jcip-annotations/ChangeLog10
-rw-r--r--dev-java/jcip-annotations/Manifest1
-rw-r--r--dev-java/jcip-annotations/jcip-annotations-1.0-r1.ebuild37
-rw-r--r--dev-java/jcip-annotations/metadata.xml14
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-java/jcip-annotations/ChangeLog b/dev-java/jcip-annotations/ChangeLog
new file mode 100644
index 000000000..abeec0e60
--- /dev/null
+++ b/dev-java/jcip-annotations/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/jcip-annotations
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*jcip-annotations-1.0-r1 (14 May 2012)
+
+ 14 May 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +jcip-annotations-1.0-r1.ebuild, +metadata.xml:
+ import from the java overlay
+
diff --git a/dev-java/jcip-annotations/Manifest b/dev-java/jcip-annotations/Manifest
new file mode 100644
index 000000000..5d5a730b5
--- /dev/null
+++ b/dev-java/jcip-annotations/Manifest
@@ -0,0 +1 @@
+DIST jcip-annotations-src.jar 4998 RMD160 a4b9a825fb0b2c313ebf5d11f246a654e30109b3 SHA1 c685e640967c817cc66d9df598772e68721161f8 SHA256 221f5cbe0b00a4c5f3c8870639de3573223fb9aa2636c631f901302fd4339efc
diff --git a/dev-java/jcip-annotations/jcip-annotations-1.0-r1.ebuild b/dev-java/jcip-annotations/jcip-annotations-1.0-r1.ebuild
new file mode 100644
index 000000000..1ee0f8510
--- /dev/null
+++ b/dev-java/jcip-annotations/jcip-annotations-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# WARNING WARNING
+# Upstream source unversioned
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Annotations for Concurrency"
+HOMEPAGE="http://www.jcip.net/"
+SRC_URI="http://www.jcip.net/${PN}-src.jar"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.5"
+#Confirm license before entering tree.
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_compile() {
+ mkdir -p build
+ ejavac -d build $(find net -name '*.java')
+ jar -cf "${PN}.jar" -C build net
+}
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ use source && java-pkg_dosrc net
+}
diff --git a/dev-java/jcip-annotations/metadata.xml b/dev-java/jcip-annotations/metadata.xml
new file mode 100644
index 000000000..ba0008fb8
--- /dev/null
+++ b/dev-java/jcip-annotations/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>ali_bush@gentoo.org</email>
+ <name>Alistair Bush</name>
+ </maintainer>
+ <longdescription lang="en">
+ Annotations used within the Java Concurrency in Practice book by
+ Brain Goetz.
+ </longdescription>
+</pkgmetadata>
+