aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-02-16 21:30:42 +0000
committerSébastien Fabbro <sebfabbro@gmail.com>2012-02-16 21:30:42 +0000
commitbce0c27350e3e12ba37fdc9136b57249c26e857b (patch)
tree4c4c27ff0826b9dba02199dcdae81396fc92fde3 /dev-lang/icc/icc-12.1.7.256.ebuild
parentdev-libs/intel-common: Version bump (diff)
downloadsci-bce0c27350e3e12ba37fdc9136b57249c26e857b.tar.gz
sci-bce0c27350e3e12ba37fdc9136b57249c26e857b.tar.bz2
sci-bce0c27350e3e12ba37fdc9136b57249c26e857b.zip
dev-lang/icc: Version bump
(Portage version: 2.1.10.44/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/icc/icc-12.1.7.256.ebuild')
-rw-r--r--dev-lang/icc/icc-12.1.7.256.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/icc/icc-12.1.7.256.ebuild b/dev-lang/icc/icc-12.1.7.256.ebuild
new file mode 100644
index 000000000..ef5059c3d
--- /dev/null
+++ b/dev-lang/icc/icc-12.1.7.256.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2405
+INTEL_DPV=2011_sp1_update1
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Intel C/C++ Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="eclipse"
+
+DEPEND="~dev-libs/intel-common-${PV}[compiler]"
+RDEPEND="${DEPEND}
+ eclipse? ( dev-util/eclipse-sdk )"
+
+QA_PREBUILT="
+ ${INTEL_SDP_DIR}/bin/*/*
+ ${INTEL_SDP_DIR}/compiler/lib/*/*
+ ${INTEL_SDP_DIR}/mpirt/bin/*/*
+ ${INTEL_SDP_DIR}/mpirt/lib/*/*"
+QA_PRESTRIPPED="${INTEL_SDP_DIR}/compiler/lib/*/.*libFNP.so"
+
+INTEL_BIN_RPMS="compilerproc compilerproc-devel"
+INTEL_DAT_RPMS="compilerproc-common"