aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois.bissey@canterbury.ac.nz>2014-08-27 15:52:41 +1200
committerFrançois Bissey <francois.bissey@canterbury.ac.nz>2014-08-27 15:52:41 +1200
commitd166beaefa32ee96bba9d3e4c3fca9c3e680d7ab (patch)
treee6af63c767b17569e4562923a8aad5ff9783bf75 /dev-lang
parentMerge branch 'master' of ssh://github.com/gentoo-science/sci (diff)
downloadsci-d166beaefa32ee96bba9d3e4c3fca9c3e680d7ab.tar.gz
sci-d166beaefa32ee96bba9d3e4c3fca9c3e680d7ab.tar.bz2
sci-d166beaefa32ee96bba9d3e4c3fca9c3e680d7ab.zip
Few fixes: julia wants threaded fftw; multilib-strict install; Added USE_BLAS64=0 to Make.user, some proprietary blas/lapack may be
suitable for the other setting but we cannot count on julia to recognize support just based on name. Package-Manager: portage-2.2.10
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/julia/ChangeLog7
-rw-r--r--dev-lang/julia/julia-9999.ebuild7
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-lang/julia/ChangeLog b/dev-lang/julia/ChangeLog
index 3816f2c4d..9a0ecfeb1 100644
--- a/dev-lang/julia/ChangeLog
+++ b/dev-lang/julia/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 27 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+ julia-9999.ebuild:
+ Few fixes: julia wants threaded fftw; multilib-strict install; Added
+ USE_BLAS64=0 to Make.user, some proprietary blas/lapack may be suitable for
+ the other setting but we cannot count on julia to recognize support just based
+ on name.
+
02 Apr 2014; Sebastien Fabbro <fabbros@gentoo.org> julia-9999.ebuild,
metadata.xml:
various consistent fixes for main tree
diff --git a/dev-lang/julia/julia-9999.ebuild b/dev-lang/julia/julia-9999.ebuild
index ae77b7076..bac01db35 100644
--- a/dev-lang/julia/julia-9999.ebuild
+++ b/dev-lang/julia/julia-9999.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
sci-libs/arpack:0=
sci-libs/camd:0=
sci-libs/cholmod:0=
- sci-libs/fftw:3.0=
+ sci-libs/fftw:3.0=[threads]
sci-libs/openlibm:0=
sci-libs/spqr:0=
sci-libs/umfpack:0=
@@ -58,7 +58,7 @@ src_prepare() {
sed -i \
-e "s|\(JULIA_EXECUTABLE = \)\(\$(JULIAHOME)/julia\)|\1 LD_LIBRARY_PATH=\$(BUILD)/$(get_libdir) \2|" \
-e "s|-O3|${CFLAGS}|g" \
- -e "s|LIBDIR = lib|LIBDIR = $(get_libdir)|" \
+ -e "s|libdir = \$(prefix)/lib|libdir = \$(prefix)/$(get_libdir)|" \
-e "s|/usr/lib|${EPREFIX}/usr/$(get_libdir)|" \
-e "s|/usr/include|${EPREFIX}/usr/include|" \
-e "s|\$(BUILD)/lib|\$(BUILD)/$(get_libdir)|" \
@@ -83,6 +83,7 @@ src_configure() {
LIBBLASNAME=$($(tc-getPKG_CONFIG) --libs blas | sed -e "s/-l\([a-z0-9]*\).*/lib\1/")
LIBLAPACK=$($(tc-getPKG_CONFIG) --libs lapack)
LIBLAPACKNAME=$($(tc-getPKG_CONFIG) --libs lapack | sed -e "s/-l\([a-z0-9]*\).*/lib\1/")
+ USE_BLAS64=0
USE_LLVM_SHLIB=1
USE_SYSTEM_ARPACK=1
USE_SYSTEM_BLAS=1
@@ -125,7 +126,7 @@ src_test() {
}
src_install() {
- emake install PREFIX="${ED}/usr"
+ emake install prefix="${ED}/usr"
cat > 99julia <<-EOF
LDPATH=${EROOT%/}/usr/$(get_libdir)/julia
EOF