aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-06-02 01:13:23 +0200
committerAndreas Schäfer <gentryx@gmx.de>2013-06-02 01:13:23 +0200
commit7f48a4daa67ffe2f4c76b6bcd6e8fae18c3111f9 (patch)
tree6c56bdf5a9ee7e67279e0b8bd0b43301a6567d44 /dev-lang
parentadded updated Manifest (diff)
downloadsci-7f48a4daa67ffe2f4c76b6bcd6e8fae18c3111f9.tar.gz
sci-7f48a4daa67ffe2f4c76b6bcd6e8fae18c3111f9.tar.bz2
sci-7f48a4daa67ffe2f4c76b6bcd6e8fae18c3111f9.zip
added PGI ebuild
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pgi/Manifest1
-rw-r--r--dev-lang/pgi/files/terminal.patch39
-rw-r--r--dev-lang/pgi/metadata.xml16
-rw-r--r--dev-lang/pgi/pgi-13.5.ebuild100
4 files changed, 156 insertions, 0 deletions
diff --git a/dev-lang/pgi/Manifest b/dev-lang/pgi/Manifest
new file mode 100644
index 000000000..27c00897e
--- /dev/null
+++ b/dev-lang/pgi/Manifest
@@ -0,0 +1 @@
+DIST pgilinux-2013-135.tar.gz 949594228 SHA256 94dc015b5758486905643a729f7ece5c68038667385cbd08406b8799fcf9a22c SHA512 1bbd26f14c6757677c30fc2f4598f2b26072d34f0fe90a8914b55b0e52472adc1d342398372581ee9eef43480b5207d7998322f9621d0993f0a82d9055b7a5c6 WHIRLPOOL ad299eb206748f921ab826093a2a728ea100b0b51f2eca30562a956ed5885791c1b6465d3877586e626bb3ba6d397e6cd0d13e8bc736f2ccbf64e2e5601e7d8f
diff --git a/dev-lang/pgi/files/terminal.patch b/dev-lang/pgi/files/terminal.patch
new file mode 100644
index 000000000..9b5b67474
--- /dev/null
+++ b/dev-lang/pgi/files/terminal.patch
@@ -0,0 +1,39 @@
+diff -ru pgi-a/install pgi/install
+--- pgi-a/install 2013-06-01 01:24:11.522714654 +0200
++++ pgi/install 2013-06-01 01:27:36.372713265 +0200
+@@ -83,7 +83,7 @@
+ else
+ licensefile=$SRC/common/BETA_LICENSE
+ fi
+-more $licensefile
++#more $licensefile
+ echo
+ echo -n 'Do you accept these terms? (accept,decline) '
+ read x
+@@ -296,7 +296,7 @@
+ echo
+ echo 'In order to install the ACML software, please read and accept the'
+ echo 'following license.'
+- more $SRC/common/LICENSE_ACML.txt
++ #more $SRC/common/LICENSE_ACML.txt
+ echo
+ echo -n 'Do you accept these terms? (accept,decline) '
+ read x
+@@ -342,7 +342,7 @@
+ echo
+ echo 'In order to install the CUDA software, please read and accept the'
+ echo 'following license.'
+- more $SRC/common/LICENSE_NVIDIA_CUDA.txt
++ #more $SRC/common/LICENSE_NVIDIA_CUDA.txt
+ echo
+ echo -n 'Do you accept these terms? (accept,decline) '
+ read x
+@@ -398,7 +398,7 @@
+ echo
+ echo 'In order to install the JAVA software, please read and accept the'
+ echo 'following license.'
+- more $SRC/common/LICENSE_JRE_6U21.txt
++ #more $SRC/common/LICENSE_JRE_6U21.txt
+ echo
+ echo -n 'Do you accept these terms? (accept,decline) '
+ read x
diff --git a/dev-lang/pgi/metadata.xml b/dev-lang/pgi/metadata.xml
new file mode 100644
index 000000000..a888d4aa8
--- /dev/null
+++ b/dev-lang/pgi/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription>
+ PGI is the C/C++/Fortran compiler suite of the Portland Group.
+ </longdescription>
+ <maintainer>
+ <email>gentryx@gmx.de</email>
+ </maintainer>
+ <use>
+ <flag name='acml'>Install AMD's core math library.</flag>
+ <flag name='java'>Install a PGI-tuned JRE.</flag>
+ <flag name='cuda'>Install PGI's CUDA components (e.g. for OpenACC)</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-lang/pgi/pgi-13.5.ebuild b/dev-lang/pgi/pgi-13.5.ebuild
new file mode 100644
index 000000000..8468e96c1
--- /dev/null
+++ b/dev-lang/pgi/pgi-13.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="PGI compiler suite"
+HOMEPAGE="http://www.pgroup.com/"
+SRC_URI="pgilinux-2013-135.tar.gz"
+LICENSE="PGI"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="acml cuda java"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="
+ opt/pgi/linux86/2013/cuda/4.2/lib/lib*.so.*
+ opt/pgi/linux86-64/13.5/bin/*
+ opt/pgi/linux86-64/13.5/lib/lib*
+ opt/pgi/linux86-64/13.5/lib/*.o
+ opt/pgi/linux86-64/13.5/libso/lib*
+ opt/pgi/linux86-64/13.5/libso/*.o
+ opt/pgi/linux86-64/13.5/cray/lib*
+ opt/pgi/linux86-64/13.5/etc/pgi_license_tool/curl
+ opt/pgi/linux86-64/13.5/REDIST/lib*.so
+ opt/pgi/linux86-64/2013/cuda/5.0/nvvm/cicc
+ opt/pgi/linux86-64/2013/cuda/4.2/nvvm/cicc
+ opt/pgi/linux86-64/2013/acml/5.3.0/lib/lib*
+ opt/pgi/linux86-64/2013/acml/5.3.0/libso/lib*.so
+ opt/pgi/linux86/13.5/etc/pgi_license_tool/curl
+ opt/pgi/linux86/13.5/bin/*
+ opt/pgi/linux86/13.5/lib/lib*
+ opt/pgi/linux86/13.5/lib/*.o
+ opt/pgi/linux86/13.5/libso/lib*
+ opt/pgi/linux86/13.5/cray/lib*
+ opt/pgi/linux86/2013/cuda/5.0/nvvm/cicc
+ opt/pgi/linux86/2013/cuda/4.2/nvvm/cicc
+ opt/pgi/linux86/2013/acml/4.4.0/lib/lib*
+ opt/pgi/linux86/2013/acml/4.4.0/libso/lib*.so
+"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "PGI doesn't provide direct download links. Please download"
+ einfo "${ARCHIVE} from ${HOMEPAGE}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/terminal.patch"
+}
+
+src_install() {
+ dodir /opt/pgi
+
+ command="accept
+1
+${ED}/opt/pgi"
+
+ if use acml; then
+ command="${command}
+y
+accept
+"
+ else
+ command="${command}
+n"
+ fi
+
+ if use cuda; then
+ command="${command}
+y
+accept"
+ else
+ command="${command}
+n"
+ fi
+
+ if use java; then
+ command="${command}
+
+accept"
+ else
+ command="${command}
+no"
+ fi
+
+ command="${command}
+y
+n
+n
+y
+"
+ ./install <<EOF
+${command}
+EOF
+}