aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-28 13:38:00 +0200
committerJustin Lecher <jlec@gentoo.org>2011-05-28 13:38:00 +0200
commit929bcb5e9d44ca0ad2ec26aa16c4f6b54267515b (patch)
tree188af45af82f89f60d90aa138e9e75b4fbd20a4b /dev-libs/intel-common/intel-common-12.0.4.191.ebuild
parentCleaned for current HEAD (diff)
downloadsci-929bcb5e9d44ca0ad2ec26aa16c4f6b54267515b.tar.gz
sci-929bcb5e9d44ca0ad2ec26aa16c4f6b54267515b.tar.bz2
sci-929bcb5e9d44ca0ad2ec26aa16c4f6b54267515b.zip
Version Bump
(Portage version: 2.2.0_alpha37/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-libs/intel-common/intel-common-12.0.4.191.ebuild')
-rw-r--r--dev-libs/intel-common/intel-common-12.0.4.191.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/intel-common/intel-common-12.0.4.191.ebuild b/dev-libs/intel-common/intel-common-12.0.4.191.ebuild
new file mode 100644
index 000000000..6e4f0d627
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-12.0.4.191.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2158
+INTEL_DPV=2011_update2
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+
+QA_PREBUILT="
+ ${INTEL_SDP_DIR}/compiler/lib/*/*
+ ${INTEL_SDP_DIR}/bin/sourcechecker/*/*/*
+ ${INTEL_SDP_DIR}/bin/*/*"
+
+QA_PRESTRIPPED="
+ ${INTEL_SDP_DIR}/compiler/lib/*/.*libFNP.so
+ ${INTEL_SDP_DIR}/bin/sourcechecker/lib/*/pinruntime/.*
+ ${INTEL_SDP_DIR}/bin/sourcechecker/*/*/.*"
+
+CHECKREQS_DISK_BUILD=256
+
+pkg_setup() {
+ einfo ${INTEL_SDP_DIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common"
+ if use compiler; then
+ INTEL_BIN_RPMS="${INTEL_BIN_RPMS} compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS="${INTEL_DAT_RPMS} compilerpro-vars sourcechecker-common"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ MANPATH=${INTEL_SDP_EDIR}/man/en_US
+ INTEL_LICENSE_FILE=${EPREFIX}/opt/intel/licenses
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+ doenvd ${fenv} || die
+
+ dodir /opt/intel/licenses
+ keepdir /opt/intel/licenses
+}