aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-01-11 14:15:04 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-01-11 14:15:04 +0100
commit047e3b9f951118c93be4c7a3722237ade79337b0 (patch)
treef094d272a684b059d54de29c1d79f60d1e608745 /dev-libs/libconfig/libconfig-9999.ebuild
parentMerge pull request #322 from marbre/libfac (diff)
downloadsci-047e3b9f951118c93be4c7a3722237ade79337b0.tar.gz
sci-047e3b9f951118c93be4c7a3722237ade79337b0.tar.bz2
sci-047e3b9f951118c93be4c7a3722237ade79337b0.zip
dev-libs/libconfig-9999: Add ebuild to overlay
Diffstat (limited to 'dev-libs/libconfig/libconfig-9999.ebuild')
-rw-r--r--dev-libs/libconfig/libconfig-9999.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libconfig/libconfig-9999.ebuild b/dev-libs/libconfig/libconfig-9999.ebuild
new file mode 100644
index 000000000..b1e1ffcf3
--- /dev/null
+++ b/dev-libs/libconfig/libconfig-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+inherit eutils autotools-multilib
+
+DESCRIPTION="Libconfig is a simple library for manipulating structured configuration files"
+HOMEPAGE="http://www.hyperrealm.com/libconfig/libconfig.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/hyperrealm/libconfig.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="http://www.hyperrealm.com/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~mips ppc ppc64 sparc x86 ~x86-linux"
+ PATCHES=( "${FILESDIR}/${P}-out-of-source-build.patch" )
+fi
+
+IUSE="+cxx examples static-libs"
+
+DEPEND="
+ sys-devel/libtool
+ sys-devel/bison"
+
+src_prepare() {
+ sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable cxx)
+ --disable-examples
+ )
+ autotools-utils_src_configure
+}
+
+multilib_src_test() {
+ # It responds to check but that does not work as intended
+ emake test
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+
+ if use examples; then
+ find examples/ -name "Makefile.*" -delete || die
+ local dir
+ for dir in examples/c examples/c++; do
+ insinto /usr/share/doc/${PF}/${dir}
+ doins ${dir}/*
+ done
+ fi
+}