aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-02-28 09:11:13 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2013-02-28 09:11:13 +0400
commit26daba777e4fe1d62e552e5891ba2ea2e109c6bf (patch)
tree7c49cbc0a5350f88af217ffd3adfdf64116b1d83 /dev-libs/papi/papi-5.1.0.2.ebuild
parentAdd ~x86 (diff)
downloadsci-26daba777e4fe1d62e552e5891ba2ea2e109c6bf.tar.gz
sci-26daba777e4fe1d62e552e5891ba2ea2e109c6bf.tar.bz2
sci-26daba777e4fe1d62e552e5891ba2ea2e109c6bf.zip
Initial import
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'dev-libs/papi/papi-5.1.0.2.ebuild')
-rw-r--r--dev-libs/papi/papi-5.1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/papi/papi-5.1.0.2.ebuild b/dev-libs/papi/papi-5.1.0.2.ebuild
new file mode 100644
index 000000000..56fab5adf
--- /dev/null
+++ b/dev-libs/papi/papi-5.1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/index.html"
+SRC_URI="http://icl.cs.utk.edu/projects/papi/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ econf \
+ --with-perf-events \
+ --with-pfm-prefix="${EPREFIX}/usr" \
+ $(use_with static-libs)
+}