aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2012-03-17 16:02:05 +0100
committerJonathan-Christofer Demay <jcdemay@gmail.com>2012-03-17 16:02:05 +0100
commit86326a3779e7330e60713dc191eef684337618c7 (patch)
tree2ebad501e4d5eb0965ff265bbe9fca5b5d7e74d9 /dev-libs/simclist/simclist-1.6.ebuild
parentsci-libs/atlas: Version bump (diff)
downloadsci-86326a3779e7330e60713dc191eef684337618c7.tar.gz
sci-86326a3779e7330e60713dc191eef684337618c7.tar.bz2
sci-86326a3779e7330e60713dc191eef684337618c7.zip
dev-libs/simclist: version bump
Diffstat (limited to 'dev-libs/simclist/simclist-1.6.ebuild')
-rw-r--r--dev-libs/simclist/simclist-1.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/simclist/simclist-1.6.ebuild b/dev-libs/simclist/simclist-1.6.ebuild
new file mode 100644
index 000000000..3a18ba936
--- /dev/null
+++ b/dev-libs/simclist/simclist-1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils
+
+DESCRIPTION="SimCList is a high quality C (C++ embeddable) library for handling lists."
+HOMEPAGE="http://mij.oltrelinux.com/devel/simclist"
+SRC_URI="${HOMEPAGE}/${P/_/}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P/_/}"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_compile(){
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ mkdir -p "${D}"/usr/include
+ cp simclist.h "${D}"/usr/include/
+ cd "${CMAKE_BUILD_DIR}"
+ dolib libsimclist.so
+ cd "${S}"
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}