aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-15 11:02:15 +0100
committerJustin Lecher <jlec@gentoo.org>2012-11-27 20:21:56 +0100
commitf93167520a051ff29d6d842a55a30e832628fe9a (patch)
treea4ff80da00ce32a4f11c1cbec01fd3144d860ab8 /dev-libs
parentimport from tree (diff)
downloadsci-f93167520a051ff29d6d842a55a30e832628fe9a.tar.gz
sci-f93167520a051ff29d6d842a55a30e832628fe9a.tar.bz2
sci-f93167520a051ff29d6d842a55a30e832628fe9a.zip
Imported from tree
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-common/ChangeLog21
-rw-r--r--dev-libs/intel-common/Manifest3
-rw-r--r--dev-libs/intel-common/intel-common-13.0.0.079-r1.ebuild59
-rw-r--r--dev-libs/intel-common/metadata.xml12
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/intel-common/ChangeLog b/dev-libs/intel-common/ChangeLog
new file mode 100644
index 000000000..22f23991b
--- /dev/null
+++ b/dev-libs/intel-common/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for dev-libs/intel-common
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.4 2012/11/14 18:34:25 bicatali Exp $
+
+ 14 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
+ Removing myself from maintainer
+
+*intel-common-13.0.0.079-r1 (28 Oct 2012)
+
+ 28 Oct 2012; Justin Lecher <jlec@gentoo.org>
+ +intel-common-13.0.0.079-r1.ebuild:
+ Mask installation from revdep-rebuild ,#438820
+
+ 20 Sep 2012; Justin Lecher <jlec@gentoo.org> intel-common-13.0.0.079.ebuild:
+ Avoid double prefix
+
+*intel-common-13.0.0.079 (16 Sep 2012)
+
+ 16 Sep 2012; Justin Lecher <jlec@gentoo.org> +intel-common-13.0.0.079.ebuild,
+ +metadata.xml:
+ Imported from sci overlay; new package containing common libs, #297542
diff --git a/dev-libs/intel-common/Manifest b/dev-libs/intel-common/Manifest
new file mode 100644
index 000000000..d22f77a92
--- /dev/null
+++ b/dev-libs/intel-common/Manifest
@@ -0,0 +1,3 @@
+DIST parallel_studio_xe_2013.tgz 2097190124 SHA256 22ac8d6dd1bf9fd646c1d1322c0a9051b89b6dba975112d492cccd8359f8dc0a SHA512 d49c519c0b2f82e6fc0db6820d5f84999d2a973d8caa0e103c0ad355644f52d209147a2b3a884effad9bbae117bd9ebbad4869f5440009355ffacb65cae274fa WHIRLPOOL bb5f05ceeae39f794dcd6c4fafafb2e5ebf8e5332083f7eaf357dddb9b2a1e94f52f82f850a8b0aefe1920f2fd21be67bfa8aafa9590707e25e84e9f2be07bd5
+DIST parallel_studio_xe_2013_ia32.tgz 1161979592 SHA256 3f0ff2ece4cfc5ec3d7c2fddefeda2b55b1295a0d62440c172a14d8e60b7b551 SHA512 9818d0e8ee1f36527f5899480381c252528274248974001f136e7aecc196ab4a049aeabed5835c18f0b08153d3a36a7fc8d850aec455bb9b5f71d95d17dc161e WHIRLPOOL 2772bb70b968f765af1c47ecb11a9e0b0220890ed37d0a81cb911f9ec43dda8cbdd85f3b0cacf1b1794ca239684f3381e54bada668b0b4a40244da684c3b04a5
+DIST parallel_studio_xe_2013_intel64.tgz 1448188683 SHA256 6d3f5a635e86bc6d71d970458d746df8f4f239e8892347d76b4eda18946048f3 SHA512 679abcb2089fc9570bad0fe8b7dd6aeb0e13831f2f79e485ce150e593e7c0d2c8c25c03520124261291f0fa418a9b873e86a81b6962ad8bbae60bc2acbc594b6 WHIRLPOOL 85ee892aac2691375edf4624842a6931b3eaab34be64b97282c025810cb2db4ea05426263af5249525724d3437da6337189e6a4af6a1efc8f7713a854b8e4ce1
diff --git a/dev-libs/intel-common/intel-common-13.0.0.079-r1.ebuild b/dev-libs/intel-common/intel-common-13.0.0.079-r1.ebuild
new file mode 100644
index 000000000..46928119a
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-13.0.0.079-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/intel-common-13.0.0.079-r1.ebuild,v 1.1 2012/10/28 15:29:55 jlec Exp $
+
+EAPI=4
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2749
+INTEL_DPV=2013
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+
+CHECKREQS_DISK_BUILD=325M
+
+pkg_setup() {
+ einfo ${INTEL_SDP_EDIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common"
+ if use compiler; then
+ INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ MANPATH=${INTEL_SDP_EDIR}/man/en_US
+ INTEL_LICENSE_FILE=${INTEL_SDP_EDIR}/licenses
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+ dodir ${INTEL_SDP_DIR}/licenses
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}
diff --git a/dev-libs/intel-common/metadata.xml b/dev-libs/intel-common/metadata.xml
new file mode 100644
index 000000000..5a311a4b5
--- /dev/null
+++ b/dev-libs/intel-common/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ This package contains the core files to be installed for the Intel
+ compilers and libraries. Probably useless if installed standalone.
+</longdescription>
+<use>
+ <flag name="compiler">Install the libraries needed for the icc and ifort compilers</flag>
+</use>
+</pkgmetadata>