aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2012-08-11 18:15:15 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2012-08-11 18:15:15 -0400
commit6b945b560cfb560f9e9db1b9e5a35447d514f0e6 (patch)
tree7f9dec8a1355cd8f926bee76e83f02e770993fc2 /dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild
parentsci-chemistry/nmrpipe: no function called from prefix.eclass; please drop (diff)
downloadsci-6b945b560cfb560f9e9db1b9e5a35447d514f0e6.tar.gz
sci-6b945b560cfb560f9e9db1b9e5a35447d514f0e6.tar.bz2
sci-6b945b560cfb560f9e9db1b9e5a35447d514f0e6.zip
[dev-ml/gsl-ocaml] new package
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild
new file mode 100644
index 000000000..991a51c1f
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml bindings for the GSL library"
+HOMEPAGE="http://bitbucket.org/mmottl/gsl-ocaml"
+SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples test"
+
+DEPEND=">=sci-libs/gsl-1.10"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.txt" "README.md" "NOTES.md" "TODO.md" )
+
+src_prepare() {
+ oasis_configure_opts="$(use_enable examples)"
+}