aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-16 11:42:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-16 11:42:22 +0100
commit7203befe74cc00b7f13c42acb713fecd7117feb6 (patch)
tree3dd4d9130639fdc5b349ff32996fce0ee5ab8a2d /dev-ml/lacaml/lacaml-11.0.8.ebuild
parentdev-lang/pgi: add missing RESTRICT="fetch" (diff)
downloadsci-7203befe74cc00b7f13c42acb713fecd7117feb6.tar.gz
sci-7203befe74cc00b7f13c42acb713fecd7117feb6.tar.bz2
sci-7203befe74cc00b7f13c42acb713fecd7117feb6.zip
dev-ml/lacaml: version bump, fix fetch and homepage
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-ml/lacaml/lacaml-11.0.8.ebuild')
-rw-r--r--dev-ml/lacaml/lacaml-11.0.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/lacaml/lacaml-11.0.8.ebuild b/dev-ml/lacaml/lacaml-11.0.8.ebuild
new file mode 100644
index 000000000..ea091d80a
--- /dev/null
+++ b/dev-ml/lacaml/lacaml-11.0.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="BLAS/LAPACK interface for OCaml"
+HOMEPAGE="https://mmottl.github.io/lacaml/"
+SRC_URI="https://github.com/mmottl/lacaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ocamlopt"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "CHANGES.txt" "TODO.md" )