aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 11:15:18 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-22 11:15:18 +0100
commitfeee3be41866e292a945d0494f9329dad2f43998 (patch)
tree5d0e27f0ad719064e7af22a35c88a3e8881b80cd /dev-ml/lacaml/lacaml-7.0.3.ebuild
parentsci-astronomy/zebra: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead... (diff)
downloadsci-feee3be41866e292a945d0494f9329dad2f43998.tar.gz
sci-feee3be41866e292a945d0494f9329dad2f43998.tar.bz2
sci-feee3be41866e292a945d0494f9329dad2f43998.zip
dev-ml/lacaml: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'dev-ml/lacaml/lacaml-7.0.3.ebuild')
-rw-r--r--dev-ml/lacaml/lacaml-7.0.3.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-ml/lacaml/lacaml-7.0.3.ebuild b/dev-ml/lacaml/lacaml-7.0.3.ebuild
index ad9fbd152..1b6d6f541 100644
--- a/dev-ml/lacaml/lacaml-7.0.3.ebuild
+++ b/dev-ml/lacaml/lacaml-7.0.3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
OASIS_BUILD_DOCS=1
-inherit oasis
+
+inherit oasis toolchain-funcs
DESCRIPTION="BLAS/LAPACK interface for OCaml"
HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
@@ -16,7 +17,8 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND="virtual/blas
+RDEPEND="
+ virtual/blas
virtual/lapack"
DEPEND="${DEPEND}
virtual/pkgconfig"
@@ -27,10 +29,10 @@ src_prepare() {
if use doc; then
cp "${FILESDIR}/API.odocl" . || die
fi
- cclib="$(pkg-config --libs blas lapack)"
+ cclib="$($(tc-getPKG_CONFIG) --libs blas lapack)"
cclib="[$(echo $cclib|sed -e 's/\(-[a-z0-9]*\) /\"\1\"\;/g' -e \
's/\(-[a-z0-9]*\)$/\"\1\"/')]"
sed -i "s/cclib = \[\]/cclib = ${cclib}/" setup.conf
#would like to do the below, but doesn't work from ebuild
- #oasis_configure_opts="--override conf_cclib $(pkg-config --libs blas lapack)"
+ #oasis_configure_opts="--override conf_cclib $($(tc-getPKG_CONFIG) --libs blas lapack)"
}