aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2011-11-14 19:26:21 -0500
committerGuillaume Horel <guillaume.horel@gmail.com>2011-11-14 19:26:21 -0500
commit578ff9363f499493086e259db93d806b08520fa8 (patch)
tree21f4126b5da301d4e86ef70087f7e4ae965ed7de /dev-ml/lacaml
parentopenbabel-perl: Redigest (diff)
downloadsci-578ff9363f499493086e259db93d806b08520fa8.tar.gz
sci-578ff9363f499493086e259db93d806b08520fa8.tar.bz2
sci-578ff9363f499493086e259db93d806b08520fa8.zip
[dev-ml/lacaml] initial import
Diffstat (limited to 'dev-ml/lacaml')
-rw-r--r--dev-ml/lacaml/ChangeLog10
-rw-r--r--dev-ml/lacaml/Manifest2
-rw-r--r--dev-ml/lacaml/lacaml-5.5.2.ebuild40
-rw-r--r--dev-ml/lacaml/metadata.xml8
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/lacaml/ChangeLog b/dev-ml/lacaml/ChangeLog
new file mode 100644
index 000000000..f771bb414
--- /dev/null
+++ b/dev-ml/lacaml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/lacaml
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*lacaml-5.5.2 (15 Nov 2011)
+
+ 15 Nov 2011; Guillaume Horel <guillaume.horel@gmail.com>
+ +lacaml-5.5.2.ebuild, +metadata.xml:
+ Original import
+
diff --git a/dev-ml/lacaml/Manifest b/dev-ml/lacaml/Manifest
new file mode 100644
index 000000000..5e1ebde95
--- /dev/null
+++ b/dev-ml/lacaml/Manifest
@@ -0,0 +1,2 @@
+DIST lacaml-5.5.2.tar.bz2 91218 RMD160 a4b8bee49f38155fa176967a6d9ee5b864c0bd4b SHA1 274811e3a7f3a6772c5701a33ea707984a62fa04 SHA256 433a502f6ebb325e6965b63a267667549d1d0786dbf8f472c36f8df941074b29
+EBUILD lacaml-5.5.2.ebuild 872 RMD160 671857598e41a2dd99acbfd9d8a4f4665e096773 SHA1 92c5b9f61b5246a84533ba899cc3eab0799b2dde SHA256 5401bb70ac6135cf159a04fe9cbdb220a8a9209435c3db61ff8dddbb3a5582b2
diff --git a/dev-ml/lacaml/lacaml-5.5.2.ebuild b/dev-ml/lacaml/lacaml-5.5.2.ebuild
new file mode 100644
index 000000000..8a17c7f71
--- /dev/null
+++ b/dev-ml/lacaml/lacaml-5.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils findlib
+
+DESCRIPTION="BLAS/LAPACK interface for OCaml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://hg.ocaml.info/release/${PN}/archive/release-${PV}.tar.bz2
+-> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ocaml[ocamlopt]
+ virtual/blas
+ virtual/lapack"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ sed -i -e "s/blas/$(pkg-config --libs blas|sed s/-l//g)/" \
+ -e "s/lapack/$(pkg-config --libs lapack|sed s/-l//g)/" Makefile.conf ||die
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.txt Changelog
+ use doc && dodoc -r doc/lacaml/html doc/lacaml/latex
+}
diff --git a/dev-ml/lacaml/metadata.xml b/dev-ml/lacaml/metadata.xml
new file mode 100644
index 000000000..8925df672
--- /dev/null
+++ b/dev-ml/lacaml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang='en'>
+BLAS/LAPACK-interface for OCaml
+</longdescription>
+</pkgmetadata>