aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-16 08:23:07 +0200
committerJustin Lecher <jlec@gentoo.org>2015-04-16 08:23:07 +0200
commit0f338fac3f7d62381a8be1ff6d55de237117b932 (patch)
tree97936438e276a3507439dbd0a46482bbba9dd844 /dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
parentIn CVS (diff)
downloadsci-0f338fac3f7d62381a8be1ff6d55de237117b932.tar.gz
sci-0f338fac3f7d62381a8be1ff6d55de237117b932.tar.bz2
sci-0f338fac3f7d62381a8be1ff6d55de237117b932.zip
In CVS
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
deleted file mode 100644
index c28be862b..000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit eutils autotools
-
-DESCRIPTION="A graph library for Objective Caml"
-HOMEPAGE="http://ocamlgraph.lri.fr"
-SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples gtk +ocamlopt"
-
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
- gtk? ( >=dev-ml/lablgtk-2.12[gnomecanvas,ocamlopt?] )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-makefile.patch"
-
- #dirty fix for doc building
- sed -i Makefile.in -e "s/-d doc -html \$(DGRAPH_INCLUDES) \$(DOC_SRC)/-d doc -html \$(DGRAPH_INCLUDES) \$(DOC_SRC:src\/merge.mli=)/g"
-
- eautoreconf
-}
-
-src_compile() {
- emake -j1 DESTDIR="/" || die "emake failed"
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES CREDITS FAQ README
-
- if use doc; then
- dohtml doc/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}