aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2016-06-05 12:03:44 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2016-06-05 12:03:44 -0400
commitc67313e237d5ffae23cd93194b90fda95197b411 (patch)
tree08d99276ec34fe3d6841a7510d21f68d8195e676 /dev-ml/zarith/zarith-1.2.1.ebuild
parentdev-ml/zarith: fix src_prepare() (diff)
downloadsci-c67313e237d5ffae23cd93194b90fda95197b411.tar.gz
sci-c67313e237d5ffae23cd93194b90fda95197b411.tar.bz2
sci-c67313e237d5ffae23cd93194b90fda95197b411.zip
dev-ml/zarith: remove since in main tree
Diffstat (limited to 'dev-ml/zarith/zarith-1.2.1.ebuild')
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
deleted file mode 100644
index cd0fa27ec..000000000
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils findlib multilib
-
-DESCRIPTION="Arithmetic and logical operations over arbitrary-precision integers"
-HOMEPAGE="http://forge.ocamlcore.org/projects/zarith"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/1199/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt doc mpir"
-
-DEPEND="
- >=dev-lang/ocaml-3.12.1[ocamlopt?]
- !mpir? ( dev-libs/gmp:0 )
- mpir? ( sci-libs/mpir:0 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- OCAMLDIR=$(ocamlc -where)
-}
-
-src_prepare(){
- default
- sed \
- -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
- -i "${S}"/project.mak || die
-}
-
-src_configure(){
- MY_OPTS="-ocamllibdir /usr/$(get_libdir) -installdir ${D}/${OCAMLDIR}"
- use mpir && MY_OPTS="${MY_OPTS} -mpir"
- ./configure ${MY_OPTS} || die "configure failed"
-}
-
-src_compile(){
- default
- use doc && emake doc
-}
-
-src_install(){
- findlib_src_preinst
- cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf || die
- default
- rm -f "${D}/${OCAMLDIR}"/ld.conf || die
- DOCS=( Changes README )
- use doc && HTML_DOCS=( html/. )
- einstalldocs
-}