aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2010-01-10 10:55:29 +0100
committerThomas Kahle <tom111@gmx.de>2010-01-10 10:55:29 +0100
commite2a31b14a821dd207d731de1687fc61b9d103b67 (patch)
tree1f278df842b8e046e440d0f8247edcb04d603f98 /dev-ml
parent[sci-geosciences/qgis] added new 1.4 live version until the release happens, (diff)
downloadsci-e2a31b14a821dd207d731de1687fc61b9d103b67.tar.gz
sci-e2a31b14a821dd207d731de1687fc61b9d103b67.tar.bz2
sci-e2a31b14a821dd207d731de1687fc61b9d103b67.zip
Adding ocamlgsl(Bug 280939) from sunrise to science.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgsl/ChangeLog11
-rw-r--r--dev-ml/ocamlgsl/Manifest5
-rw-r--r--dev-ml/ocamlgsl/files/ocaml-3.11.patch31
-rw-r--r--dev-ml/ocamlgsl/metadata.xml5
-rw-r--r--dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild37
5 files changed, 89 insertions, 0 deletions
diff --git a/dev-ml/ocamlgsl/ChangeLog b/dev-ml/ocamlgsl/ChangeLog
new file mode 100644
index 000000000..f0007f4d9
--- /dev/null
+++ b/dev-ml/ocamlgsl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamlgsl
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 10 Jan 2010; Thomas Kahle <tom111@gmx.de> ChangeLog:
+ Adding dev-ml/ocamlgsl to the science overlay as a dependency
+
+ 17 Aug 2009; Guillaume Horel (thrasibule) <guillaume.horel@gmail.com>
+ +ocamlgsl-0.6.0.ebuild, +files/ocaml-3.11.patch, +metadata.xml:
+ New Ebuild for dev-ml/ocamlgsl (bug #280939)
+
diff --git a/dev-ml/ocamlgsl/Manifest b/dev-ml/ocamlgsl/Manifest
new file mode 100644
index 000000000..51417420c
--- /dev/null
+++ b/dev-ml/ocamlgsl/Manifest
@@ -0,0 +1,5 @@
+AUX ocaml-3.11.patch 948 RMD160 6230348d7b3aea03fad9e139b062ef16824159ae SHA1 963844c2209a922c73c8c102021eecc16e439038 SHA256 e025e4bf6a0635001cbd73211417a1056ebf9361db540fb707813260e040b195
+DIST ocamlgsl-0.6.0.tar.gz 274345 RMD160 f7e9db2f388694dbede5b95ed961cb6eeef1fb00 SHA1 819d2f95f44cc4c331a4aa644f8d23704477de05 SHA256 ddb9e432dc1a431cad332a8e7e6685d2facbde2fa15ecab9315741f7d11b588c
+EBUILD ocamlgsl-0.6.0.ebuild 812 RMD160 b8ad19eeed6edb90aca71cf2b4ff93d480a078e5 SHA1 e9829eaab27d9d85d56c38c932172b526f27382f SHA256 2c6b9c02ca44a4b52d824d3ba203ce03ba983eb9a51548fce15b4d34f4257a40
+MISC ChangeLog 422 RMD160 f204cc54f1273a8b899204cb5c942e414a0d7db9 SHA1 0e69d3de21a8c52eaa94a2ed3e4203b989e17784 SHA256 443f3f65030fb29834175ae427b383c95ad5a3bd3cf423dda539b0c66bc419a6
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-ml/ocamlgsl/files/ocaml-3.11.patch b/dev-ml/ocamlgsl/files/ocaml-3.11.patch
new file mode 100644
index 000000000..52627ac24
--- /dev/null
+++ b/dev-ml/ocamlgsl/files/ocaml-3.11.patch
@@ -0,0 +1,31 @@
+ Makefile | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae12602..dd68657 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,12 +16,12 @@ OCPP := ocpp
+ FORT := fort
+ AWK := gawk
+
+-MNOCYGWIN ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) "NR==1 { print \$$3 }")
++MNOCYGWIN ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) 'NR==1 { print $3 }')
+ ifeq ($(MNOCYGWIN),-mnocygwin)
+ OCAML_BACKEND := mingw
+ endif
+
+-OCAML_BACKEND ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) "NR==1 { print \$$2 }")
++OCAML_BACKEND ?= $(shell $(OCAMLC) -verbose foo.c 2>&1 | $(AWK) 'NR==1 { print $2 }')
+ OCAML_VERSION ?= $(shell $(OCAMLC) -version)
+
+ OCAMLBCFLAGS := -g
+@@ -94,7 +94,7 @@ SRC := wrappers.h gsl_misc.ml io.h \
+ ifeq ($(OCAML_BACKEND),cl)
+ include msvc.mak
+ else
+-ifeq ($(OCAML_BACKEND),gcc)
++ifneq (,$(findstring gcc,$(OCAML_BACKEND)))
+ include gcc.mak
+ else
+ include mingw.mak
diff --git a/dev-ml/ocamlgsl/metadata.xml b/dev-ml/ocamlgsl/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-ml/ocamlgsl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
new file mode 100644
index 000000000..7b241e779
--- /dev/null
+++ b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit base findlib
+
+DESCRIPTION="OCaml bindings for the GSL library"
+HOMEPAGE="http://oandrieu.nerim.net/ocaml/gsl/"
+SRC_URI="http://oandrieu.nerim.net/ocaml/gsl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.10
+ >=sci-libs/gsl-1.9"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}/ocaml-3.11.patch" )
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install-findlib || die "make install failed"
+
+ dodoc README NEWS NOTES || die "docs install failed"
+ doinfo *.info* || die "info install failed"
+ if use doc; then
+ dohtml doc/* || die "html docs install failed"
+ fi
+}