aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-06-16 01:37:00 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-06-16 01:37:00 +0100
commit408a7618ab8fa166637d5e1a7215a6843f692cf6 (patch)
tree9fbc13d01b9a9259253a6229738b7f2d9935fdae /dev-perl
parentsci-astronomy/scamp: Fixed patch name (diff)
downloadsci-408a7618ab8fa166637d5e1a7215a6843f692cf6.tar.gz
sci-408a7618ab8fa166637d5e1a7215a6843f692cf6.tar.bz2
sci-408a7618ab8fa166637d5e1a7215a6843f692cf6.zip
dev-perl/PDL: Version bump
(Portage version: 2.1.10.63/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/PDL/ChangeLog11
-rw-r--r--dev-perl/PDL/Manifest1
-rw-r--r--dev-perl/PDL/PDL-2.4.11.ebuild112
-rw-r--r--dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch20
-rw-r--r--dev-perl/PDL/files/PDL-2.4.4-PIC.patch22
-rw-r--r--dev-perl/PDL/files/perldl.conf110
-rw-r--r--dev-perl/PDL/metadata.xml26
7 files changed, 302 insertions, 0 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
new file mode 100644
index 000000000..17ed7ea34
--- /dev/null
+++ b/dev-perl/PDL/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/PDL
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*PDL-2.4.11 (16 Jun 2012)
+
+ 16 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/PDL-2.4.2-makemakerfix.patch, +files/PDL-2.4.4-PIC.patch,
+ +PDL-2.4.11.ebuild, +files/perldl.conf, +metadata.xml:
+ Version bump
+
diff --git a/dev-perl/PDL/Manifest b/dev-perl/PDL/Manifest
new file mode 100644
index 000000000..fac9a712e
--- /dev/null
+++ b/dev-perl/PDL/Manifest
@@ -0,0 +1 @@
+DIST PDL-2.4.11.tar.gz 2859537 RMD160 7c877c7477930a0a874190670aedc6375746c63d SHA1 c9fa6ea585c09bf6f9e1e9a0370c985894cfe0c1 SHA256 c777ed2519d73ebde0d870e94931a2d2c57865abcee27dfec53f4412a2cac662 SHA512 014358b7d844a082552782f23d610d62b6f5bf5fccef30dc32ecad665501e278351cf3b33ceafe3387054d2063fc642b7bf56459944ee8c0c3d0d7cef3d78a2b WHIRLPOOL eb6623dce01e0f568ddcd2d399a8ddb394ab839b088347a51c5c73c8cacf91b726cd18f6692e50197ae9040eec9dcb4bc3fa7bb722c66ea316132764d40fa8d4
diff --git a/dev-perl/PDL/PDL-2.4.11.ebuild b/dev-perl/PDL/PDL-2.4.11.ebuild
new file mode 100644
index 000000000..28e98d42f
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.11.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.7.ebuild,v 1.3 2010/08/23 13:39:54 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=CHM
+inherit eutils fortran-2 perl-module
+
+HOMEPAGE="http://pdl.perl.org/"
+DESCRIPTION="Perl Data Language scientific computing"
+
+LICENSE="Artistic as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="badval doc fftw gd gsl hdf netpbm opengl pdl2 proj pgplot plplot threads"
+
+RDEPEND="sys-libs/ncurses
+ app-arch/sharutils
+ dev-perl/Astro-FITS-Header
+ >=dev-perl/ExtUtils-F77-1.13
+ dev-perl/File-Map
+ dev-perl/Inline
+ dev-perl/TermReadKey
+ || ( dev-perl/Term-ReadLine-Perl dev-perl/Term-ReadLine-Gnu )
+ virtual/perl-Data-Dumper
+ virtual/perl-PodParser
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Filter
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ fftw? ( sci-libs/fftw:2.1 )
+ gd? ( media-libs/gd )
+ gsl? ( sci-libs/gsl )
+ hdf? ( sci-libs/hdf )
+ netpbm? ( media-libs/netpbm virtual/ffmpeg )
+ pdl2? ( dev-perl/Devel-REPL )
+ proj? ( sci-libs/proj )
+ opengl? ( dev-perl/OpenGL )
+ pgplot? ( dev-perl/PGPLOT )
+ plplot? ( sci-libs/plplot )"
+
+DEPEND="${RDEPEND}
+ virtual/fortran"
+
+mydoc="BUGS DEPENDENCIES DEVELOPMENT Known_problems MANIFEST* Release_Notes"
+
+SRC_TEST="do"
+
+#MAKEOPTS+=" -j1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.2-makemakerfix.patch
+ # Unconditional -fPIC for the lib (#55238, #180807, #250335)
+ epatch "${FILESDIR}"/${PN}-2.4.4-PIC.patch
+}
+
+src_configure() {
+ pdl_use() {
+ local p=${2:-WITH_${1^^}}
+ if use $1; then
+ echo "-e \"/${p}/s/=>.*/=> 1/\""
+ else
+ echo "-e \"/${p}/s/=>.*/=> 0/\""
+ fi
+ }
+ sed -i \
+ -e '/USE_POGL/s/=>.*/=> 1,/' \
+ -e '/WITH_MINUIT/s/=>.*/=> 1,/' \
+ -e '/WITH_SLATEC/s/=>.*/=> 1,/' \
+ -e "/WITH_BADVAL/s/=>.*/=> $(use badval && echo true || echo false),/" \
+ -e "/HTML_DOCS/s/=>.*/=> $(use doc && echo 1 || echo 0),/" \
+ -e "/WITH_FFTW/s/=>.*/=> $(use fftw && echo true || echo false),/" \
+ -e "/WITH_GSL/s/=>.*/=> $(use gsl && echo true || echo false),/" \
+ -e "/WITH_GD/s/=>.*/=> $(use gd && echo true || echo false),/" \
+ -e "/WITH_HDF/s/=>.*/=> $(use hdf && echo true || echo false),/" \
+ -e "/WITH_3D/s/=>.*/=> $(use opengl && echo true || echo false),/" \
+ -e "/WITH_PGPLOT/s/=>.*/=> $(use pgplot && echo 1 || echo 0),/" \
+ -e "/WITH_PLPLOT/s/=>.*/=> $(use plplot && echo 1 || echo 0),/" \
+ -e "/WITH_PROJ/s/=>.*/=> $(use proj && echo true || echo false),/" \
+ -e "/WITH_DEVEL_REPL/s/=>.*/=> $(use pdl2 && echo true || echo false),/" \
+ -e "/WITH_POSIX_THREADS/s/=>.*/=> $(use threads && echo true || echo 0),/" \
+ perldl.conf || die
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+ insinto /${VENDOR_ARCH}/PDL/Doc
+ doins Doc/{scantree.pl,mkhtmldoc.pl}
+}
+
+pkg_postinst() {
+ if [[ ${EROOT} = / ]] ; then
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreatethis at any time"
+ elog "by running"
+ else
+ elog "You must create perldl.db by running"
+ fi
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
+ elog "PDL requires that glx and dri support be enabled in"
+ elog "your X configuration for certain parts of the graphics"
+ elog "engine to work. See your X's documentation for futher"
+ elog "information."
+}
+
+pkg_prerm() {
+ rm -rf "${EROOT}"/var/lib/pdl/html
+ rm -f "${EROOT}"/var/lib/pdl/pdldoc.db "${EROOT}"/var/lib/pdl/Index.pod
+}
diff --git a/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch b/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch
new file mode 100644
index 000000000..6cf2c4009
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch
@@ -0,0 +1,20 @@
+--- Demos/BAD2_demo.pm.PL 2006/04/20 07:42:24 1.1
++++ Demos/BAD2_demo.pm.PL 2006/04/20 07:42:32
+@@ -3,6 +3,7 @@
+ # - requires both bad-value support and PGPLOT
+ #
+
++use blib;
+ use strict;
+
+ use Config;
+--- Demos/BAD_demo.pm.PL 2006/04/20 07:42:17 1.1
++++ Demos/BAD_demo.pm.PL 2006/04/20 07:42:38
+@@ -3,6 +3,7 @@
+ # - needed since we allow bad pixel handling to be switched off
+ #
+
++use blib;
+ use strict;
+
+ use Config;
diff --git a/dev-perl/PDL/files/PDL-2.4.4-PIC.patch b/dev-perl/PDL/files/PDL-2.4.4-PIC.patch
new file mode 100644
index 000000000..a0087c9f5
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.4-PIC.patch
@@ -0,0 +1,22 @@
+--- Lib/Minuit/Makefile.PL
++++ Lib/Minuit/Makefile.PL
+@@ -149,7 +149,7 @@
+ ("
+
+ minuitlib/$_\$(OBJ_EXT): minuitlib/$_.f
+- $mycompiler -c $hack_64bit -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
++ $mycompiler -c -fPIC -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
+ " )} @minuitfiles;
+
+ if (!defined($PDL::Config{MINUIT_LIB})){
+--- Lib/Slatec/Makefile.PL
++++ Lib/Slatec/Makefile.PL
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ $mycompiler -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }
diff --git a/dev-perl/PDL/files/perldl.conf b/dev-perl/PDL/files/perldl.conf
new file mode 100644
index 000000000..1fe24f3db
--- /dev/null
+++ b/dev-perl/PDL/files/perldl.conf
@@ -0,0 +1,110 @@
+# -*-perl-*-
+
+# PDL Configuration options
+
+# You can edit this here or say 'perl Makefile.PL PDLCONF=file'
+# or use ~/.perldl.conf
+
+# Note in general "0" means False, "1" means "True" and "undef"
+# means "Try if possible (e.g. because the library is found)"
+
+%PDL_CONFIG = (
+
+# Use posix threading to make use of multiprocessor machines
+# undef -> try if possible
+# 0 -> don't use
+# true -> force use
+
+ WITH_POSIX_THREADS => undef,
+
+ MALLOCDBG => undef,
+# {
+# include => '-I/home/csoelle/tmp',
+# libs => '-L/home/csoelle/tmp -lmymalloc',
+# define => << 'EOD',
+##define malloc(n) dbgmalloc(n,__FILE__,__LINE__)
+##define free(p) dbgfree(p)
+#EOD
+# include => '',
+# libs => '-lefence',
+# define => '',
+# },
+
+# Do we want routines to handle bad values?
+# saying no will make PDL a bit faster
+# true -> yes
+# false -> no, undef -> no
+#
+ WITH_BADVAL => 0,
+# WITH_BADVAL => 1,
+
+# if WITH_BADVAL == 1, do we use NaN/Inf to represent badvalues
+# (not convinced setting this results in faster code)
+#
+ BADVAL_USENAN => 0,
+# BADVAL_USENAN => 1,
+
+# Try to build Graphics/TriD
+ WITH_3D => undef,
+#
+# For Mesa 3.2
+#
+ OPENGL_LIBS => '-L/usr/lib -lGL -lGLU -L/usr/X11R6/lib -lXext -lX11',
+#
+# Mesa need -DGL_GLEXT_LEGACY for glPolygonOffsetEXT amoung others
+#
+ OPENGL_DEFINE => '-DGL_GLEXT_LEGACY',
+ OPENGL_INC => '-I/usr/include',
+#
+#
+# For SGI GL
+#
+# OPENGL_LIBS => '-lGL -lGLU -lXext -lX11',
+# OPENGL_INC => '',
+# OPENGL_DEFINE => '',
+#
+# Let perl try to figure it out
+# OPENGL_LIBS => undef,
+# OPENGL_INC => undef,
+# OPENGL_DEFINE => undef,
+# Whether or not to build the Karma interface module
+
+ WITH_KARMA => undef, # Leave it up to PDL to decide
+ WHERE_KARMA => undef, # you may explicitly specify directory location
+
+# Whether or not to build the PDL::Slatec module
+# 0 -> don't use
+# true -> force use
+
+ WITH_SLATEC => undef, # Leave it up to PDL to decide
+
+# Whether or not to build the PDL::GSL module
+# 0 -> don't use
+# true -> force use
+
+ WITH_GSL => undef, # Leave it up to PDL to decide
+
+# Location to search for the GSL libs
+ GSL_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find GSL includes:
+ GSL_INC => '-I/usr/include/gsl -I/usr/local/include',
+
+# Whether or not to build the PDL::FFTW module
+# 0 -> don't use
+# true -> force use
+
+ WITH_FFTW => undef, # Leave it up to PDL to decide
+
+# Location to search for the FFTW libs
+ FFTW_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find FFTW includes:
+ FFTW_INC => ['/usr/include/','/usr/local/include'],
+
+# FFTW Numeric Precision Type to link in: (double or single precision)
+ FFTW_TYPE => 'double',
+
+);
+
+1; # Return OK status on 'require'
+
+
diff --git a/dev-perl/PDL/metadata.xml b/dev-perl/PDL/metadata.xml
new file mode 100644
index 000000000..8ea87deae
--- /dev/null
+++ b/dev-perl/PDL/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Perl Data Language gives standard perl the ability to compactly
+ store and speedily manipulate the large N-dimensional data arrays
+ which are the bread and butter of scientific computing. The idea
+ is to turn perl in to a free, array-oriented, numerical language
+ in the same sense as commercial packages like IDL and MatLab. One
+ can write simple perl expressions to manipulate entire numerical
+ arrays all at once.
+</longdescription>
+<use>
+ <flag name="badval">Enable badval support</flag>
+ <flag name="hdf">Enable HDF support</flag>
+ <flag name="netpbm">Enable NETPBM support</flag>
+ <flag name="pdl2">Build pdf2 experimental shell</flag>
+ <flag name="proj">Enable NETPBM support</flag>
+ <flag name="pgplot">Enable PGPLOT support</flag>
+ <flag name="plplot">Enable plplot support</flag>
+</use>
+<upstream>
+ <remote-id type="cpan">PDL</remote-id>
+</upstream>
+</pkgmetadata>