aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-07-30 10:42:53 -0400
committerHorea Christian <chr@chymera.eu>2024-07-30 10:42:53 -0400
commitc764cd6c28a6329b3c5cb9ed16e2334069aaba44 (patch)
tree65adf07402510092395ed655ca9665c84ff44692 /dev-python/hdmf/hdmf-3.14.3.ebuild
parentdev-python/pynwb: enable py3.12 (diff)
downloadsci-c764cd6c28a6329b3c5cb9ed16e2334069aaba44.tar.gz
sci-c764cd6c28a6329b3c5cb9ed16e2334069aaba44.tar.bz2
sci-c764cd6c28a6329b3c5cb9ed16e2334069aaba44.zip
dev-python/hdmf: add 3.14.3
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/hdmf/hdmf-3.14.3.ebuild')
-rw-r--r--dev-python/hdmf/hdmf-3.14.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hdmf/hdmf-3.14.3.ebuild b/dev-python/hdmf/hdmf-3.14.3.ebuild
new file mode 100644
index 000000000..f79f23765
--- /dev/null
+++ b/dev-python/hdmf/hdmf-3.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The Hierarchical Data Modeling Framework"
+HOMEPAGE="https://github.com/hdmf-dev/hdmf"
+SRC_URI="$(pypi_sdist_url hdmf)"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ "
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-3.11.0-no_test_coverage.patch"
+# )
+
+distutils_enable_tests pytest