aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-22 07:56:08 -0400
committerHorea Christian <chr@chymera.eu>2023-05-22 07:56:16 -0400
commit8d5fe1bdb23b95225f1053fdca66e7f7e4b676dd (patch)
treec2e2a50709b395c4224d205f23cf9f51f8c03bf9 /dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
parentsci-biology/dcmstack: drop 0.8 (diff)
downloadsci-8d5fe1bdb23b95225f1053fdca66e7f7e4b676dd.tar.gz
sci-8d5fe1bdb23b95225f1053fdca66e7f7e4b676dd.tar.bz2
sci-8d5fe1bdb23b95225f1053fdca66e7f7e4b676dd.zip
dev-python/heudiconv: update SRC_URI, test fix
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild')
-rw-r--r--dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild b/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
index 847424235..048890f37 100644
--- a/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
+++ b/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
@@ -4,15 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
DESCRIPTION="Flexible DICOM conversion to structured directory layouts"
HOMEPAGE="
https://github.com/nipy/heudiconv
https://heudiconv.readthedocs.io/en/latest/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="Apache-2.0"
@@ -29,6 +28,7 @@ RDEPEND="
"
BDEPEND="
test? (
+ dev-python/mock[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
)
"
@@ -39,4 +39,8 @@ PATCHES=(
"${FILESDIR}/${P}-gitenv.patch"
)
+EPYTEST_DESELECT=(
+ heudiconv/tests/test_main.py::test_prepare_for_datalad
+)
+
distutils_enable_tests pytest