aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-10-21 23:00:45 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-10-21 23:00:45 +0200
commit848964f604ae83d7121fc45b7a7bfcb4705cabdb (patch)
treee8006e39b2056259b2658724b21131341a8b7502 /dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild
parentdev-python/ipykernel: Version bump to 4.1.1, drop 4.1.0 (diff)
downloadsci-848964f604ae83d7121fc45b7a7bfcb4705cabdb.tar.gz
sci-848964f604ae83d7121fc45b7a7bfcb4705cabdb.tar.bz2
sci-848964f604ae83d7121fc45b7a7bfcb4705cabdb.zip
dev-python/matplotlib2tikz: Version bump to 0.2.4
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild
new file mode 100644
index 000000000..db655fe90
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python script for converting matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"