aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-10-12 09:09:11 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-10-12 09:09:11 +0200
commit1ed88b3f6385598b9376b24e454264e9542758a0 (patch)
tree4e970f9f0b3df51c5ffc014b782ede6cf74aa621 /dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-1ed88b3f6385598b9376b24e454264e9542758a0.tar.gz
sci-1ed88b3f6385598b9376b24e454264e9542758a0.tar.bz2
sci-1ed88b3f6385598b9376b24e454264e9542758a0.zip
dev-python/matplotlib2tikz: Version bump to 0.5.14
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild
new file mode 100644
index 000000000..8a22daf5c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"