aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-04-25 10:53:28 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-04-25 10:53:28 +0200
commit4b3c5cccb9eb4e78d0f0bd2ab79e7258ad64ecfa (patch)
tree03d79002dbde239ffa2b1585e0f36ee079584816 /dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild
parentsci-libs/clfft: Version bump (diff)
downloadsci-4b3c5cccb9eb4e78d0f0bd2ab79e7258ad64ecfa.tar.gz
sci-4b3c5cccb9eb4e78d0f0bd2ab79e7258ad64ecfa.tar.bz2
sci-4b3c5cccb9eb4e78d0f0bd2ab79e7258ad64ecfa.zip
dev-python/matplotlib2tikz: Version bump; drop old
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild
new file mode 100644
index 000000000..ec78e4f0b
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"