aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-07 17:15:35 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-07 17:15:35 +0000
commitcb1a6f0783161ba9d4859dbd7b35f4f7d12a0c7f (patch)
treeacccad55320fe24d03b4d908b313d38f4b4affbd /dev-python/numpy
parentadded algae-4.3.6 (diff)
downloadsci-cb1a6f0783161ba9d4859dbd7b35f4f7d12a0c7f.tar.gz
sci-cb1a6f0783161ba9d4859dbd7b35f4f7d12a0c7f.tar.bz2
sci-cb1a6f0783161ba9d4859dbd7b35f4f7d12a0c7f.zip
numpy-0.9.8: blocks f2py. tested with gcc-4.1
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@225 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog9
-rw-r--r--dev-python/numpy/Manifest4
-rw-r--r--dev-python/numpy/numpy-0.9.8.ebuild13
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 7bd9241bb..8b2d5151b 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -2,11 +2,16 @@
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jun 2006; Sebastien Fabbro <seb@ist.utl.pt> numpy-0.9.8.ebuild:
+ Blocks f2py (closes bug #131833). Tested with gcc-4.1, works.
+ Does not compile with as-needed. Cleaning.
+
*numpy-0.9.8 (30 May 2006)
30 May 2006; Sebastien Fabbro <seb@ist.utl.pt> +numpy-0.9.8.ebuild:
- Version bump. Changed homepage.
-
+ Version bump. Changed homepage. Blocks f2py (closes bug #131833)
+ Tested with gcc-4.1, works. Does not compile with as-needed.
+
*numpy-0.9.6-r1 (11 Apr 2006)
11 Apr 2006; Sebastien Fabbro <seb@ist.utl.pt> +numpy-0.9.6-r1.ebuild:
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 624ad2b58..a3f9edf9b 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,5 +1,5 @@
-MD5 678efbebdaf7f7a91c909bcf9ef950b7 ChangeLog 1036
+MD5 ef225442df457a1a9b0b84d8b266f378 ChangeLog 1315
MD5 3d1644c7fef9abd10cb81c674838b436 files/digest-numpy-0.9.6-r1 63
MD5 8f0b986d41688c7bf8b416bc3d1844e9 files/digest-numpy-0.9.8 63
MD5 9185a676f9b9d796c4d7aaf5c91b9895 numpy-0.9.6-r1.ebuild 1281
-MD5 676da0fa8756c208acb6436aae93cfca numpy-0.9.8.ebuild 1277
+MD5 55b21085df71f18a937e406ec6d26e04 numpy-0.9.8.ebuild 1304
diff --git a/dev-python/numpy/numpy-0.9.8.ebuild b/dev-python/numpy/numpy-0.9.8.ebuild
index f321a99d1..c891e6ef5 100644
--- a/dev-python/numpy/numpy-0.9.8.ebuild
+++ b/dev-python/numpy/numpy-0.9.8.ebuild
@@ -4,14 +4,15 @@
inherit distutils
-DESCRIPTION="Powerful N-dimensional array object and processing for Python."
+DESCRIPTION="Multi-dimensional array object and processing for Python."
SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
HOMEPAGE="http://www.scipy.org/"
-# temp fix force atlas, while eselect gets ready.
-DEPEND=">=dev-lang/python-2.3
- lapack? ( sci-libs/blas-atlas )
- lapack? ( sci-libs/lapack-atlas )"
IUSE="lapack"
+
+# force atlas, while eselect blas/lapack gets more usable
+DEPEND=">=dev-lang/python-2.3
+ !dev-python/f2py
+ lapack? ( sci-libs/blas-atlas sci-libs/lapack-atlas )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
LICENSE="BSD"
@@ -20,7 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # sed to patch ATLAS libraries names
+ # sed to patch ATLAS libraries names (gentoo specific)
sed -i \
-e "s:f77blas: blas:g" \
-e "s:'f77blas':'blas':g" \