aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-27 14:25:27 -0500
committerHorea Christian <chr@chymera.eu>2023-01-27 14:25:27 -0500
commite28d8bbb875df719a3bdd60f7a455337a3037a8e (patch)
tree6bf8134520028ad37d896ca5cd586f0123740b91 /dev-python/numpy
parentdev-python/traits: PYTHON_COMPAT bump (diff)
downloadsci-e28d8bbb875df719a3bdd60f7a455337a3037a8e.tar.gz
sci-e28d8bbb875df719a3bdd60f7a455337a3037a8e.tar.bz2
sci-e28d8bbb875df719a3bdd60f7a455337a3037a8e.zip
dev-python/numpy: new package, add 1.23.5
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/Manifest4
-rw-r--r--dev-python/numpy/files/numpy-1.22.0-no-hardcode-blasv2.patch50
-rw-r--r--dev-python/numpy/metadata.xml24
-rw-r--r--dev-python/numpy/numpy-1.23.5.ebuild187
4 files changed, 265 insertions, 0 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
new file mode 100644
index 000000000..fdd711d83
--- /dev/null
+++ b/dev-python/numpy/Manifest
@@ -0,0 +1,4 @@
+DIST numpy-1.23.5.tar.gz 10731755 BLAKE2B d2ed6d359a51343a1618f64604e4d5c030115caa63f2aadf2fc150775630e40fbebaad28f5657faae1365264fd45bc9efb00854bf9cd393b7628c96d6fc87db9 SHA512 8f3ece76dbe79bc887275332d25f851ade2087de3026de5fb7ed793590b3e7d274f590357296e152373b4e9a245d4d563393ba7198bca6d44631b941acb89c2c
+DIST numpy-html-1.23.5.zip 27964271 BLAKE2B 0aa26d7c39f2d6b119e404dfb9642967770881ee0d640157a9ed11d16f21cd43109bed3c08f89fda457ec470292d945e2bf8b2dab56e4b36192d5e8eb3757b44 SHA512 218a2e893816af767c7cedd1f2256e05f68e59491c29277c95de653a206aaff35c5fe3bc6afd6d6d5ea7957748ec565593eb30d004e36e94c894ea4a6884902a
+DIST numpy-ref-1.23.5.pdf 7715485 BLAKE2B 7fbb0ce29e86fc7cd4932a6a9f0221b579b6cae695231edfebf863e5b4c2920796d802ccf9ae3e05b331964ac7c4f51099578d91b6b7fb357c6de2110a5f7cba SHA512 6036c6a36f332b83f371c7530a6ba6f354b1334d667d2a52993a1e52aa9d94d524e216f768928a006c717ed4b4131879f6e491a294ecfd3a0d1b0f9f937a887a
+DIST numpy-user-1.23.5.pdf 4123384 BLAKE2B d4587c9f979e1ef4734768598d6e106f2b4b0c8222f901a6c4caf0920e41622201252c5bd172b16346e0357138b5ff27c59e56c851be5ae3b7712624bd9cc5b4 SHA512 58e1ab96d2cfbd96df205c86f0a1a09e204349f70d21df7f8481c21ded8b46f4b9ede3216d5cce6c2b9bfc0aacbecdfa198bdb2d4c258a0dd4acb6e3ba421f9c
diff --git a/dev-python/numpy/files/numpy-1.22.0-no-hardcode-blasv2.patch b/dev-python/numpy/files/numpy-1.22.0-no-hardcode-blasv2.patch
new file mode 100644
index 000000000..d87a16a4b
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.22.0-no-hardcode-blasv2.patch
@@ -0,0 +1,50 @@
+Originally added in: https://gitweb.gentoo.org/repo/gentoo.git/commit/dev-python/numpy/files?id=e5ce90a04e79f6413604e96e4803cb95ada7c859
+https://bugs.gentoo.org/567938
+--- a/numpy/distutils/system_info.py
++++ b/numpy/distutils/system_info.py
+@@ -505,33 +505,7 @@ def get_info(name, notfound_action=0):
+ 'blas_armpl': blas_armpl_info,
+ 'lapack_armpl': lapack_armpl_info,
+ 'fftw3_armpl': fftw3_armpl_info,
+- 'atlas': atlas_info, # use lapack_opt or blas_opt instead
+- 'atlas_threads': atlas_threads_info, # ditto
+- 'atlas_blas': atlas_blas_info,
+- 'atlas_blas_threads': atlas_blas_threads_info,
+- 'lapack_atlas': lapack_atlas_info, # use lapack_opt instead
+- 'lapack_atlas_threads': lapack_atlas_threads_info, # ditto
+- 'atlas_3_10': atlas_3_10_info, # use lapack_opt or blas_opt instead
+- 'atlas_3_10_threads': atlas_3_10_threads_info, # ditto
+- 'atlas_3_10_blas': atlas_3_10_blas_info,
+- 'atlas_3_10_blas_threads': atlas_3_10_blas_threads_info,
+- 'lapack_atlas_3_10': lapack_atlas_3_10_info, # use lapack_opt instead
+- 'lapack_atlas_3_10_threads': lapack_atlas_3_10_threads_info, # ditto
+- 'flame': flame_info, # use lapack_opt instead
+- 'mkl': mkl_info,
+- # openblas which may or may not have embedded lapack
+- 'openblas': openblas_info, # use blas_opt instead
+- # openblas with embedded lapack
+- 'openblas_lapack': openblas_lapack_info, # use blas_opt instead
+- 'openblas_clapack': openblas_clapack_info, # use blas_opt instead
+- 'blis': blis_info, # use blas_opt instead
+- 'lapack_mkl': lapack_mkl_info, # use lapack_opt instead
+- 'blas_mkl': blas_mkl_info, # use blas_opt instead
+ 'accelerate': accelerate_info, # use blas_opt instead
+- 'openblas64_': openblas64__info,
+- 'openblas64__lapack': openblas64__lapack_info,
+- 'openblas_ilp64': openblas_ilp64_info,
+- 'openblas_ilp64_lapack': openblas_ilp64_lapack_info,
+ 'x11': x11_info,
+ 'fft_opt': fft_opt_info,
+ 'fftw': fftw_info,
+@@ -951,10 +925,7 @@ class system_info:
+ return [b for b in [a.strip() for a in libs.split(',')] if b]
+
+ def get_libraries(self, key='libraries'):
+- if hasattr(self, '_lib_names'):
+- return self.get_libs(key, default=self._lib_names)
+- else:
+- return self.get_libs(key, '')
++ return self.get_libs(key, '')
+
+ def library_extensions(self):
+ c = customized_ccompiler()
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
new file mode 100644
index 000000000..26b229a9c
--- /dev/null
+++ b/dev-python/numpy/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ NumPy is a general-purpose array-processing Python package designed to
+ efficiently manipulate large multi-dimensional arrays of arbitrary
+ records without sacrificing too much speed for small multi-dimensional
+ arrays. There are also basic facilities for discrete fourier transform,
+ basic linear algebra and random number generation.
+ It is the successor of Numeric and numarray.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">numpy/numpy</remote-id>
+ <remote-id type="pypi">numpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/numpy/numpy-1.23.5.ebuild b/dev-python/numpy/numpy-1.23.5.ebuild
new file mode 100644
index 000000000..51be775b9
--- /dev/null
+++ b/dev-python/numpy/numpy-1.23.5.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 toolchain-funcs
+
+DOC_PV=${PV}
+# For when docs aren't ready yet, set to last version
+#DOC_PV=1.23.0
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="
+ https://numpy.org/
+ https://github.com/numpy/numpy/
+ https://pypi.org/project/numpy/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-html.zip -> numpy-html-${DOC_PV}.zip
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-ref.pdf -> numpy-ref-${DOC_PV}.pdf
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-user.pdf -> numpy-user-${DOC_PV}.pdf
+ )
+"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack"
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/cython-0.29.30[${PYTHON_USEDEP}]
+ lapack? (
+ virtual/pkgconfig
+ )
+ doc? (
+ app-arch/unzip
+ )
+ test? (
+ >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/numpy-1.22.0-no-hardcode-blasv2.patch
+)
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/numpy-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+python_prepare_all() {
+ # Allow use with setuptools 60.x
+ # See numpy-1.22.1-revert-setuptools-upper-bound.patch for details
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ if use lapack; then
+ local incdir="${EPREFIX}"/usr/include
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = ${incdir}
+ library_dirs = ${libdir}
+ blas_libs = cblas,blas
+ [lapack]
+ library_dirs = ${libdir}
+ lapack_libs = lapack
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+
+ append-flags -fno-strict-aliasing
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ append-fflags -fPIC
+ if use lapack; then
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+
+ # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ export MAKEOPTS=-j1 #660754
+
+ distutils-r1_python_compile ${NUMPY_FCONFIG}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very disk- and memory-hungry
+ numpy/lib/tests/test_io.py::test_large_zip
+
+ # precision problems
+ numpy/core/tests/test_umath_accuracy.py::TestAccuracy::test_validate_transcendentals
+
+ # runs the whole test suite recursively, that's just crazy
+ numpy/core/tests/test_mem_policy.py::test_new_policy
+
+ # very slow, unlikely to be practically useful
+ numpy/typing/tests/test_typing.py
+ )
+
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
+ # Degenerate case. arm32 chroot on arm64.
+ # bug #774108
+ EPYTEST_DESELECT+=(
+ numpy/core/tests/test_cpu_features.py::Test_ARM_Features::test_features
+ )
+ fi
+
+ if use x86 ; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/numpy/numpy/issues/18388
+ numpy/core/tests/test_umath.py::TestRemainder::test_float_remainder_overflow
+ # https://github.com/numpy/numpy/issues/18387
+ numpy/random/tests/test_generator_mt19937.py::TestRandomDist::test_pareto
+ # more precision problems
+ numpy/core/tests/test_einsum.py::TestEinsum::test_einsum_sums_int16
+ )
+ fi
+ if use arm || use x86 ; then
+ EPYTEST_DESELECT+=(
+ # too large for 32-bit platforms
+ numpy/core/tests/test_ufunc.py::TestUfunc::test_identityless_reduction_huge_array
+ )
+ fi
+
+ distutils_install_for_testing --single-version-externally-managed \
+ --record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG}
+
+ cd "${TEST_DIR}/lib" || die
+ epytest -k "not _fuzz"
+}
+
+python_install() {
+ # https://github.com/numpy/numpy/issues/16005
+ local mydistutilsargs=( build_src )
+ distutils-r1_python_install ${NUMPY_FCONFIG}
+ python_optimize
+}
+
+python_install_all() {
+ local DOCS=( LICENSE.txt README.md THANKS.txt )
+
+ if use doc; then
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf )
+ fi
+
+ distutils-r1_python_install_all
+}