aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-02-10 16:51:19 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-02-10 16:51:19 +0100
commit4cfc280f8fa76eca1a690c00e704f6112444c43c (patch)
tree989c7b2c1a53a226c369bc2d8e41ed49e26f9429 /dev-python/pyfftw
parentsci-biology/portrait: new package (diff)
downloadsci-4cfc280f8fa76eca1a690c00e704f6112444c43c.tar.gz
sci-4cfc280f8fa76eca1a690c00e704f6112444c43c.tar.bz2
sci-4cfc280f8fa76eca1a690c00e704f6112444c43c.zip
dev-python/pyfftw: Version bumo to 0.10.1, tests currently disabled
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/pyfftw')
-rw-r--r--dev-python/pyfftw/Manifest1
-rw-r--r--dev-python/pyfftw/pyfftw-0.10.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyfftw/Manifest b/dev-python/pyfftw/Manifest
index a1bbaac64..2087df709 100644
--- a/dev-python/pyfftw/Manifest
+++ b/dev-python/pyfftw/Manifest
@@ -1 +1,2 @@
+DIST pyFFTW-0.10.1.tar.gz 350018 SHA256 fe1c45154ecebbe1f765db25fdb774d09b17178f520b6be74ef6e213b899099d SHA512 8e1a8e8d30d65a0d9b97986c32483ae917ec66c034db6b027ec4a30ff924a08e23b6b55e6479130655fa9964ce6b3f0f7413bd800e641c88ff4b1b11b7a6bfe3 WHIRLPOOL dc0bd4c185398e1c3a3d0427b948d0cf8b79bc73b3203e48b68bcee1ee478ecb552bd36848b96bcdee13ce7e98efc3ae6cd0f36007c792c8e8dfd1a1f86cfcd5
DIST pyFFTW-0.9.2.tar.gz 336928 SHA256 f6bbb6afa93085409ab24885a1a3cdb8909f095a142f4d49e346f2bd1b789074 SHA512 f77e52ce36c9375dbd48ebfd848884c9d9a1e080df920f28f10db5350549011de62fa1cb3ec96d1b1450d8a45209e97a0b20ece43eea16d7e543581c8444d194 WHIRLPOOL 473759c40cb6701edde861e7ecb681c5091a4aa3a678e448bd840c944a2f4f6965a9b843989b076cdbf05dbb1ea3204f1555033fb985a8210ae4ad3c872f8241
diff --git a/dev-python/pyfftw/pyfftw-0.10.1.ebuild b/dev-python/pyfftw/pyfftw-0.10.1.ebuild
new file mode 100644
index 000000000..60229367a
--- /dev/null
+++ b/dev-python/pyfftw/pyfftw-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+MY_PN="pyFFTW"
+
+DESCRIPTION="FFTW wrapper for python"
+HOMEPAGE="http://hgomersall.github.io/pyFFTW/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="
+ >=dev-python/numpy-1.8.0[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3.3
+ >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+#current python_test() broken
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+
+ cp "${S}"/setup.py "${TEST_DIR}"/lib/ || die
+ cp -r "${S}"/test "${TEST_DIR}"/lib/ || die
+ esetup.py test || die
+}