aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-09-04 06:29:10 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2008-09-04 06:29:10 +0000
commit4fca02076fe1b7c7cfc8328ce51d12fa99ba458b (patch)
tree0d6136aab9e1582fca232d0e1409ab212dc94476 /dev-python/pyglet/pyglet-1.1.1.ebuild
parentThe GIS Django branch was merged into the trunk. (diff)
downloadsci-4fca02076fe1b7c7cfc8328ce51d12fa99ba458b.tar.gz
sci-4fca02076fe1b7c7cfc8328ce51d12fa99ba458b.tar.bz2
sci-4fca02076fe1b7c7cfc8328ce51d12fa99ba458b.zip
pyglet-1.1.1.ebuild: version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1274 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-python/pyglet/pyglet-1.1.1.ebuild')
-rw-r--r--dev-python/pyglet/pyglet-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyglet/pyglet-1.1.1.ebuild b/dev-python/pyglet/pyglet-1.1.1.ebuild
new file mode 100644
index 000000000..f28055b3f
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A cross-platform windowing and multimedia library in pure Python."
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="http://pyglet.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg doc examples"
+
+RDEPEND="virtual/opengl
+ || ( dev-python/ctypes >=dev-lang/python-2.5 )
+ ffmpeg? ( media-libs/avbin-bin )"
+
+src_install() {
+ DOCS="NOTICE"
+ distutils_src_install
+
+ use doc && dohtml -A txt,py -r doc/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}