aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-06-26 06:00:26 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-06-26 06:00:26 +0100
commit809803fe6391f32629a7fd3e528924b7ee3a6fb9 (patch)
tree56f63986d48d72e9b2f271863c8388dccf13642f /dev-python/pywcs/pywcs-1.4.2.ebuild
parentInitial import of aplpy (diff)
downloadsci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.tar.gz
sci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.tar.bz2
sci-809803fe6391f32629a7fd3e528924b7ee3a6fb9.zip
Initial import pywcs
Diffstat (limited to 'dev-python/pywcs/pywcs-1.4.2.ebuild')
-rw-r--r--dev-python/pywcs/pywcs-1.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pywcs/pywcs-1.4.2.ebuild b/dev-python/pywcs/pywcs-1.4.2.ebuild
new file mode 100644
index 000000000..01b04e7ba
--- /dev/null
+++ b/dev-python/pywcs/pywcs-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+NEED_PYTHON=2.4
+inherit distutils
+
+WCS_V=4.3
+MYP="${P}-${WCS_V}"
+
+DESCRIPTION="Python routines for handling the FITS World Coordinate System"
+HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
+
+DEPEND="dev-python/pyfits"
+# FIX: wcslib is shipped
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="AURA"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ # FIX: does not work, needs fits files
+ PYTHONPATH=$(dir -d build/lib*) "${python}" test/test.py || die
+}