aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-04-28 17:22:54 +0200
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-04-28 17:22:54 +0200
commit6f252642dba03de652fbdcdc11f8b6821bf9e977 (patch)
tree2879e8ff2fd3eb944f4c50e24765baf277689251 /dev-python/vo/files
parentdev-python/pywcs-1.8.1: updating dependencies and Python style (diff)
downloadsci-6f252642dba03de652fbdcdc11f8b6821bf9e977.tar.gz
sci-6f252642dba03de652fbdcdc11f8b6821bf9e977.tar.bz2
sci-6f252642dba03de652fbdcdc11f8b6821bf9e977.zip
dev-python/vo: removing docs, updating deps and Python style
Diffstat (limited to 'dev-python/vo/files')
-rw-r--r--dev-python/vo/files/vo-0.5-docs.patch (renamed from dev-python/vo/files/vo-0.3.1-docs.patch)24
-rw-r--r--dev-python/vo/files/vo-0.5-expat.patch23
2 files changed, 25 insertions, 22 deletions
diff --git a/dev-python/vo/files/vo-0.3.1-docs.patch b/dev-python/vo/files/vo-0.5-docs.patch
index 5e8061793..0bb09121c 100644
--- a/dev-python/vo/files/vo-0.3.1-docs.patch
+++ b/dev-python/vo/files/vo-0.5-docs.patch
@@ -1,14 +1,5 @@
---- doc/Makefile.orig 2009-07-21 21:23:57.000000000 +0100
-+++ doc/Makefile 2009-07-21 21:37:35.000000000 +0100
-@@ -2,7 +2,7 @@
- #
-
- # You can set these variables from the command line.
--SPHINXOPTS =
-+SPHINXOPTS =
- SPHINXBUILD = sphinx-build
- PAPER =
-
+--- doc/Makefile
++++ doc/Makefile
@@ -20,6 +20,7 @@
@echo " json to make JSON files"
@echo " htmlhelp to make HTML files and a HTML help project"
@@ -28,14 +19,3 @@
changes:
mkdir -p build/changes build/doctrees
$(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) build/changes
---- doc/source/sphinxext/inheritance_diagram.py.orig 2009-07-21 21:23:12.000000000 +0100
-+++ doc/source/sphinxext/inheritance_diagram.py 2009-07-21 21:23:33.000000000 +0100
-@@ -41,7 +41,7 @@
-
- from docutils.nodes import Body, Element
- from docutils.writers.html4css1 import HTMLTranslator
--from sphinx.latexwriter import LaTeXTranslator
-+from sphinx.writers.latex import LaTeXTranslator
- from docutils.parsers.rst import directives
- from sphinx.roles import xfileref_role
-
diff --git a/dev-python/vo/files/vo-0.5-expat.patch b/dev-python/vo/files/vo-0.5-expat.patch
new file mode 100644
index 000000000..7bbd7a84a
--- /dev/null
+++ b/dev-python/vo/files/vo-0.5-expat.patch
@@ -0,0 +1,23 @@
+Using system expat
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- setup.py
++++ setup.py
+@@ -13,14 +13,9 @@
+
+ iterparse_ext = Extension(
+ "vo.iterparser",
+- ["src/iterparse.c",
+- "src/expat/xmlparse.c",
+- "src/expat/xmlrole.c",
+- "src/expat/xmltok.c",
+- "src/expat/xmltok_impl.c",
+- "src/expat/xmltok_ns.c"],
++ ["src/iterparse.c",],
+ define_macros=defines,
+- include_dirs=["src", "src/expat"])
++ libraries=["expat"])
+
+ setup(name="vo",
+ version="0.5",