aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-10-08 17:03:40 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-10-08 17:03:40 +0100
commitf52c3bb22a35dec59c2f95ca530f14d6cec1a9e1 (patch)
tree6098ffd947b3ed946dcd0a85964563febf5ce0b7 /dev-python/vo/vo-0.4.ebuild
parentatpy bump (diff)
downloadsci-f52c3bb22a35dec59c2f95ca530f14d6cec1a9e1.tar.gz
sci-f52c3bb22a35dec59c2f95ca530f14d6cec1a9e1.tar.bz2
sci-f52c3bb22a35dec59c2f95ca530f14d6cec1a9e1.zip
vo version bump
Diffstat (limited to 'dev-python/vo/vo-0.4.ebuild')
-rw-r--r--dev-python/vo/vo-0.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/vo/vo-0.4.ebuild b/dev-python/vo/vo-0.4.ebuild
new file mode 100644
index 000000000..8ed1f14c1
--- /dev/null
+++ b/dev-python/vo/vo-0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils distutils
+
+DESCRIPTION="Python module to read VOTABLE into a Numpy recarray"
+HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${P}.tar.gz"
+
+DEPEND="doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="AURA"
+# buggy test
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.1-docs.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd doc
+ PYTHONPATH=$(dir -d ../build/lib*) emake html pdf || die
+ fi
+}
+
+src_test() {
+ cd test
+ PYTHONPATH=$(dir -d ../build/lib*) "${python}" test.py || die
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ cd doc/build
+ insinto /usr/share/doc/${PF}
+ doins -r html latex/*.pdf || die
+ fi
+}