aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-04-28 17:22:54 +0200
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-04-28 17:22:54 +0200
commit6f252642dba03de652fbdcdc11f8b6821bf9e977 (patch)
tree2879e8ff2fd3eb944f4c50e24765baf277689251 /dev-python/vo/vo-0.5.ebuild
parentdev-python/pywcs-1.8.1: updating dependencies and Python style (diff)
downloadsci-6f252642dba03de652fbdcdc11f8b6821bf9e977.tar.gz
sci-6f252642dba03de652fbdcdc11f8b6821bf9e977.tar.bz2
sci-6f252642dba03de652fbdcdc11f8b6821bf9e977.zip
dev-python/vo: removing docs, updating deps and Python style
Diffstat (limited to 'dev-python/vo/vo-0.5.ebuild')
-rw-r--r--dev-python/vo/vo-0.5.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/dev-python/vo/vo-0.5.ebuild b/dev-python/vo/vo-0.5.ebuild
index 1c319922b..72fde7795 100644
--- a/dev-python/vo/vo-0.5.ebuild
+++ b/dev-python/vo/vo-0.5.ebuild
@@ -3,38 +3,35 @@
# $Header: $
EAPI=2
-inherit distutils
+PYTHON_DEPEND="2:2.6"
+
+inherit distutils eutils
DESCRIPTION="Python module to read VOTABLE into a Numpy recarray"
HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
SRC_URI="http://stsdas.stsci.edu/astrolib/${P}.tar.gz"
-DEPEND="doc? ( >=dev-python/sphinx-0.6 )"
-RDEPEND=""
-
-IUSE="doc"
+IUSE="test"
SLOT="0"
KEYWORDS="~amd64 ~x86"
LICENSE="AURA"
-src_compile() {
- distutils_src_compile
- if use doc; then
- cd doc
- PYTHONPATH=$(dir -d ../build/lib*) emake html pdf || die
- fi
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+RDEPEND="dev-libs/expat"
+
+pkg_setup() {
+ python_set_active_version 2
}
-src_test() {
- cd test
- PYTHONPATH=$(dir -d ../build/lib*) "${python}" test.py || die
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-expat.patch
}
-src_install() {
- distutils_src_install
- if use doc; then
- cd doc/build
- insinto /usr/share/doc/${PF}
- doins -r html latex/*.pdf || die
- fi
+#FIX ME: docs are no longer built (missing stsci_sphinxext )
+
+src_test() {
+ cd test
+ PYTHONPATH=$(dir -d ../build/lib.*) "$(PYTHON)" test.py || die
}