aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2010-07-21 18:13:10 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2010-07-21 18:13:10 +0100
commitf0f603c1398b1e54d09f8e119112ff588e355f4d (patch)
treeff18a55bf2240979fe492ead2e1fc15d122cd1f5 /dev-python/vo/vo-0.6.ebuild
parent[sci-geosciences/qgis-1.5.0] keyword unstable (diff)
downloadsci-f0f603c1398b1e54d09f8e119112ff588e355f4d.tar.gz
sci-f0f603c1398b1e54d09f8e119112ff588e355f4d.tar.bz2
sci-f0f603c1398b1e54d09f8e119112ff588e355f4d.zip
vo bumped
Diffstat (limited to 'dev-python/vo/vo-0.6.ebuild')
-rw-r--r--dev-python/vo/vo-0.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/vo/vo-0.6.ebuild b/dev-python/vo/vo-0.6.ebuild
new file mode 100644
index 000000000..3fa4e72a0
--- /dev/null
+++ b/dev-python/vo/vo-0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+#PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="Python module to read VOTABLE into a Numpy recarray"
+HOMEPAGE="https://www.stsci.edu/trac/ssb/astrolib/"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${P}.tar.gz"
+
+IUSE="examples"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="AURA"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-expat.patch
+}
+
+#FIXME: tests are buggy, sphinx misses stsci_sphinx.conf
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die
+ fi
+}