aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-22 08:09:47 -0400
committerHorea Christian <chr@chymera.eu>2023-05-22 08:09:47 -0400
commit15dcbe44fc9963aae2b1e5f4c1cb5fa694878911 (patch)
treeb0aa3454414cf20f72f61c4a22127aca910b009e /dev-python
parentdev-python/heudiconv: update SRC_URI, test fix (diff)
downloadsci-15dcbe44fc9963aae2b1e5f4c1cb5fa694878911.tar.gz
sci-15dcbe44fc9963aae2b1e5f4c1cb5fa694878911.tar.bz2
sci-15dcbe44fc9963aae2b1e5f4c1cb5fa694878911.zip
dev-python/heudiconv: version bump and test failure comment
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/heudiconv/Manifest1
-rw-r--r--dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild2
-rw-r--r--dev-python/heudiconv/heudiconv-0.13.0.ebuild42
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/heudiconv/Manifest b/dev-python/heudiconv/Manifest
index 55669a6ad..e3afb5ed5 100644
--- a/dev-python/heudiconv/Manifest
+++ b/dev-python/heudiconv/Manifest
@@ -1 +1,2 @@
DIST heudiconv-0.11.6.tar.gz 9070519 BLAKE2B df6c66080bbaa89f74490f136674eabd64e9b2844ae7daef82ef4b4ef8c42ed16d3ae3b790534cc13ec121e63de8486838eb7e7becbcdbffff2df6e8bd2bd54c SHA512 c4d1f0caaed9713360ad2614bc276f2cc0e356c54b1b37c8912d762db429313c75d0f081886cb6ea0b8fd171bc5fc5a338fd3b670a8b10a3fbed0c6f9dfb7477
+DIST heudiconv-0.13.0.tar.gz 9158053 BLAKE2B 9f87fbcd5ea8ccca39cc029f1bdd84906412a22e5d18e2afe280d19737f0dda4c03248ba93f58c06aae4b15366477e8a5d1c41d09d1b1d3a10ff673aaa050e26 SHA512 b867ee0a60ad98099a3802e290ebb24b858befbd45e93772fafe437a87ea867c5076680ea3ed7856272397267c740ef2eade9f64ffc0d4216d4a37be39add158
diff --git a/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild b/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
index 048890f37..8dbfcfa0f 100644
--- a/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
+++ b/dev-python/heudiconv/heudiconv-0.11.6-r1.ebuild
@@ -39,6 +39,8 @@ PATCHES=(
"${FILESDIR}/${P}-gitenv.patch"
)
+# Reported upstream:
+# https://github.com/nipy/heudiconv/issues/679
EPYTEST_DESELECT=(
heudiconv/tests/test_main.py::test_prepare_for_datalad
)
diff --git a/dev-python/heudiconv/heudiconv-0.13.0.ebuild b/dev-python/heudiconv/heudiconv-0.13.0.ebuild
new file mode 100644
index 000000000..7f7db0b0e
--- /dev/null
+++ b/dev-python/heudiconv/heudiconv-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible DICOM conversion to structured directory layouts"
+HOMEPAGE="
+ https://github.com/nipy/heudiconv
+ https://heudiconv.readthedocs.io/en/latest/
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/versioningit[${PYTHON_USEDEP}]
+ sci-biology/dcm2niix
+ sci-biology/dcmstack[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/nipype[${PYTHON_USEDEP}]
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upstream:
+# https://github.com/nipy/heudiconv/issues/679
+EPYTEST_DESELECT=(
+ heudiconv/tests/test_main.py::test_prepare_for_datalad
+)
+
+distutils_enable_tests pytest