aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jon Booker <joe@neoturbine.net>2014-08-08 15:32:43 -0400
committerJoseph Jon Booker <joe@neoturbine.net>2014-08-08 15:32:43 -0400
commit4807b3e1869c7ab0efb0a758c658bdbe64d7003f (patch)
tree26b9c2a474ae7e88dadb696b0b8effb71fab9b58 /dev-python
parentdev-python/astropy-helpers: Add astropy-helpers package (diff)
downloadsci-4807b3e1869c7ab0efb0a758c658bdbe64d7003f.tar.gz
sci-4807b3e1869c7ab0efb0a758c658bdbe64d7003f.tar.bz2
sci-4807b3e1869c7ab0efb0a758c658bdbe64d7003f.zip
dev-python/ccdproc: Add ccdproc package
Package-Manager: portage-2.2.11-r1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ccdproc/ChangeLog10
-rw-r--r--dev-python/ccdproc/Manifest1
-rw-r--r--dev-python/ccdproc/ccdproc-0.2.ebuild59
-rw-r--r--dev-python/ccdproc/ccdproc-9999.ebuild59
-rw-r--r--dev-python/ccdproc/metadata.xml10
5 files changed, 139 insertions, 0 deletions
diff --git a/dev-python/ccdproc/ChangeLog b/dev-python/ccdproc/ChangeLog
new file mode 100644
index 000000000..ffd42973b
--- /dev/null
+++ b/dev-python/ccdproc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/ccdproc
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ccdproc-0.2 (08 Aug 2014)
+*ccdproc-9999 (08 Aug 2014)
+
+ 08 Aug 2014; Joseph Jon Booker <joe@neoturbine.net> +ccdproc-0.2.ebuild,
+ +ccdproc-9999.ebuild, +metadata.xml:
+ dev-python/ccdproc: Add ccdproc package
diff --git a/dev-python/ccdproc/Manifest b/dev-python/ccdproc/Manifest
new file mode 100644
index 000000000..1c2be2d26
--- /dev/null
+++ b/dev-python/ccdproc/Manifest
@@ -0,0 +1 @@
+DIST ccdproc-0.2.tar.gz 480410 SHA256 4be572f7fb6d87ff4ded744485fe76a699a132ed6777d3971eb88dcfe5c34d3a SHA512 36e8938ac29e317ce1d4055ed1ba8a985499904c5caea06bbd0b50b8abf31e9248d46754bf7c2f721e0174f51af27cc94870db0e48dee2a8adde620fe9c5f376 WHIRLPOOL 0bb93d0712d40641412a610231264315d50389c71c70482af73b56ff27d27b9af62e15bd683d12461700df25c374356de63e8f80d4fdf7fad9335642a387792b
diff --git a/dev-python/ccdproc/ccdproc-0.2.ebuild b/dev-python/ccdproc/ccdproc-0.2.ebuild
new file mode 100644
index 000000000..dff455d77
--- /dev/null
+++ b/dev-python/ccdproc/ccdproc-0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+inherit distutils-r1
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astropy/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
+HOMEPAGE="https://github.com/astropy/ccdproc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+DOCS=( README.rst )
+
+RDEPEND="
+ >=dev-python/astropy-0.4[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ "${EPYTHON}" -c "import ${PN}, sys;r = ${PN}.test(verbose=True);sys.exit(r)" \
+ || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ccdproc/ccdproc-9999.ebuild b/dev-python/ccdproc/ccdproc-9999.ebuild
new file mode 100644
index 000000000..dff455d77
--- /dev/null
+++ b/dev-python/ccdproc/ccdproc-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+inherit distutils-r1
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astropy/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
+HOMEPAGE="https://github.com/astropy/ccdproc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+DOCS=( README.rst )
+
+RDEPEND="
+ >=dev-python/astropy-0.4[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ "${EPYTHON}" -c "import ${PN}, sys;r = ${PN}.test(verbose=True);sys.exit(r)" \
+ || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ccdproc/metadata.xml b/dev-python/ccdproc/metadata.xml
new file mode 100644
index 000000000..3cbb671a6
--- /dev/null
+++ b/dev-python/ccdproc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
+ ccdproc is a AstroPy-affliated package for the basic reduction of
+ CCD images. It provides a framework for accounting for error propagation
+ and bad pixel tracking through the reduction steps.
+ </longdescription>
+</pkgmetadata>