aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 10:08:40 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 10:08:40 +0100
commit6e39d77176d8811efb2af398b7671a6e6a9405db (patch)
tree65128e71ef9a592aa0e9ee7bf0316a6821f96a6a /dev-python
parentsci-chemistry/gromacs: merge change from 5.1.9999 (diff)
parentdev-python/nilearn: moved deps to DEPEND (diff)
downloadsci-6e39d77176d8811efb2af398b7671a6e6a9405db.tar.gz
sci-6e39d77176d8811efb2af398b7671a6e6a9405db.tar.bz2
sci-6e39d77176d8811efb2af398b7671a6e6a9405db.zip
Merge pull request #521 from TheChymera/nilearn
dev-python/nilearn: new package
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nilearn/ChangeLog35
-rw-r--r--dev-python/nilearn/Manifest1
-rw-r--r--dev-python/nilearn/metadata.xml20
-rw-r--r--dev-python/nilearn/nilearn-0.1.4.1.ebuild36
-rw-r--r--dev-python/nilearn/nilearn-9999.ebuild34
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/nilearn/ChangeLog b/dev-python/nilearn/ChangeLog
new file mode 100644
index 000000000..e3359f136
--- /dev/null
+++ b/dev-python/nilearn/ChangeLog
@@ -0,0 +1,35 @@
+# ChangeLog for dev-python/nilearn
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Id$
+
+ 19 Nov 2015; <chymera@gentoo.org> nilearn-0.1.4.1.ebuild,
+ nilearn-9999.ebuild:
+ dev-python/nilearn: moved deps to DEPEND
+
+ 19 Nov 2015; <chymera@gentoo.org> nilearn-0.1.4.1.ebuild,
+ nilearn-9999.ebuild:
+ dev-python/nilearn: added test flag and test dependency
+
+ 14 Nov 2015; Horea Christian <h.chr@mail.ru> nilearn-0.1.4.1.ebuild:
+ dev-python/nilearn: added test function
+
+ 19 Oct 2015; Horea Christian <h.chr@mail.ru> nilearn-9999.ebuild:
+ dev-python/nilearn: plot use flag in live ebuild as well
+
+ 19 Oct 2015; Horea Christian <h.chr@mail.ru> metadata.xml,
+ nilearn-0.1.4.1.ebuild:
+ dev-python/nilearn: added plot use flag, added MY_PV, removed deprecated
+ dependency version
+
+ 19 Oct 2015; Horea Christian <h.chr@mail.ru> nilearn-9999.ebuild:
+ dev-python/nilearn: dropped empty IUSE, added PYTHON_USEDEP
+
+ 19 Oct 2015; Horea Christian <h.chr@mail.ru> nilearn-0.1.4.1.ebuild:
+ dev-python/nilearn: corrected format, added PYTHON_USEDEP, removed emtty IUSE
+
+*nilearn-0.1.4.1 (19 Oct 2015)
+*nilearn-9999 (19 Oct 2015)
+
+ 19 Oct 2015; Horea Christian <h.chr@mail.ru> +metadata.xml,
+ +nilearn-0.1.4.1.ebuild, +nilearn-9999.ebuild:
+ dev-python/nilearn: new package
diff --git a/dev-python/nilearn/Manifest b/dev-python/nilearn/Manifest
new file mode 100644
index 000000000..b4adea076
--- /dev/null
+++ b/dev-python/nilearn/Manifest
@@ -0,0 +1 @@
+DIST nilearn-0.1.4.1.tar.gz 649510 SHA256 50a1aec049ffb5691a57113aed5fa3a028add157127310b8c97e2dc4d3a9fc24 SHA512 277633d1280a69ee69452bf7c6ce3ae8a86be3165575904bdae590488d568e82804eac0a7d040fd0ff49f546adf4bd2b0899c4b3bbbfd92aedb0fc16cc10d9f7 WHIRLPOOL 64a23e2d7d1dd37361875f138be27c5d41b2014eb2d4c3ce5dfce57ea7fb59747217ca77d4f1b13e2b45f2a0f7e344bb1c22c680f60f41900e572494e3103589
diff --git a/dev-python/nilearn/metadata.xml b/dev-python/nilearn/metadata.xml
new file mode 100644
index 000000000..8b114349c
--- /dev/null
+++ b/dev-python/nilearn/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <longdescription lang="en">
+ Nilearn is a Python module for fast and easy statistical learning on NeuroImaging data.
+ It leverages the scikit-learn Python toolbox for multivariate statistics with applications
+ such as predictive modelling, classification, decoding, or connectivity analysis.
+ </longdescription>
+ <use>
+ <flag name="plot">Adds optional dependency needed for plotting function subset.</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">nilearn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nilearn/nilearn-0.1.4.1.ebuild b/dev-python/nilearn/nilearn-0.1.4.1.ebuild
new file mode 100644
index 000000000..a57bbbcf2
--- /dev/null
+++ b/dev-python/nilearn/nilearn-0.1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PV="0.1.4.post1"
+DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
+HOMEPAGE="http://nilearn.github.io/"
+SRC_URI="mirror://pypi/n/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plot test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ plot? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_test() {
+ emake test-code
+}
diff --git a/dev-python/nilearn/nilearn-9999.ebuild b/dev-python/nilearn/nilearn-9999.ebuild
new file mode 100644
index 000000000..ab5a4af9a
--- /dev/null
+++ b/dev-python/nilearn/nilearn-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
+HOMEPAGE="http://nilearn.github.io/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/nilearn/nilearn"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="+plot test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ plot? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+
+src_test() {
+ emake test-code
+}