aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 14:19:04 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:30 +0200
commit9c7debcbe932408a115954e00cfe4b4d541a8c5f (patch)
tree2fdc7cab779c606a51431b4ae5e23d6b5a7fcdf3 /dev-python
parentsci-physics/decaylanguage: new package, add 0.18.5 (diff)
downloadsci-9c7debcbe932408a115954e00cfe4b4d541a8c5f.tar.gz
sci-9c7debcbe932408a115954e00cfe4b4d541a8c5f.tar.bz2
sci-9c7debcbe932408a115954e00cfe4b4d541a8c5f.zip
dev-python/resample: new package, add 1.10.1
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/resample/Manifest1
-rw-r--r--dev-python/resample/metadata.xml19
-rw-r--r--dev-python/resample/resample-1.10.1.ebuild19
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/resample/Manifest b/dev-python/resample/Manifest
new file mode 100644
index 000000000..347f41acf
--- /dev/null
+++ b/dev-python/resample/Manifest
@@ -0,0 +1 @@
+DIST resample-1.10.1.tar.gz 631943 BLAKE2B e76817a4cfc6b1a04a7a601ba8e2c23d5ef38dac815ec244b0ff7af1a470c5a3dc2fbdd51af142443350369fcfb15a492fcfb84f32888097075a15e4d9408c31 SHA512 4e9ce268c375960f75e5e43bd22e304ef33f7ffe7e9ad894bd4f71bace81f1cb81d11e0486a4e09af72fae3106a3a5155be315b6d69a9d28499d39dfe451f053
diff --git a/dev-python/resample/metadata.xml b/dev-python/resample/metadata.xml
new file mode 100644
index 000000000..db0565d2f
--- /dev/null
+++ b/dev-python/resample/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ Resampling-based inference in Python based on data resampling and permutation.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">resample</remote-id>
+ <remote-id type="github">scikit-hep/resample</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/resample/resample-1.10.1.ebuild b/dev-python/resample/resample-1.10.1.ebuild
new file mode 100644
index 000000000..424c9c537
--- /dev/null
+++ b/dev-python/resample/resample-1.10.1.ebuild
@@ -0,0 +1,19 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Randomization-based inference in Python"
+HOMEPAGE="https://github.com/scikit-hep/resample"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.10[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest