aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-09 15:04:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-03-09 15:04:08 +0100
commit6de5dbd94259c5955fdfdcd2510f034ea444097d (patch)
tree1e4d95ff27760a8bfc07bbfa2447a5a15030fa1f /dev-tex/pythontex/pythontex-9999.ebuild
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-6de5dbd94259c5955fdfdcd2510f034ea444097d.tar.gz
sci-6de5dbd94259c5955fdfdcd2510f034ea444097d.tar.bz2
sci-6de5dbd94259c5955fdfdcd2510f034ea444097d.zip
dev-tex/pythontex: Version BUmp
Package-Manager: portage-2.2.18
Diffstat (limited to 'dev-tex/pythontex/pythontex-9999.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-9999.ebuild50
1 files changed, 21 insertions, 29 deletions
diff --git a/dev-tex/pythontex/pythontex-9999.ebuild b/dev-tex/pythontex/pythontex-9999.ebuild
index 5e7ac367a..92b36ac07 100644
--- a/dev-tex/pythontex/pythontex-9999.ebuild
+++ b/dev-tex/pythontex/pythontex-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
-inherit latex-package python-single-r1 git-r3
+inherit latex-package python-r1 git-r3
DESCRIPTION="Fast Access to Python from within LaTeX"
HOMEPAGE="https://github.com/gpoore/pythontex"
@@ -21,46 +21,38 @@ IUSE="highlighting"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
- app-text/texlive"
+ dev-texlive/texlive-latex"
RDEPEND="${DEPEND}
dev-texlive/texlive-xetex
>=dev-python/matplotlib-1.2.0[${PYTHON_USEDEP}]
highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-src_prepare() {
- S="${WORKDIR}/${P}/${PN}"
- cd "${S}" || die
- rm pythontex.sty || die "Could not remove pre-compiled pythontex.sty!"
-}
+TEXMF=/usr/share/texmf-site
src_compile() {
+ cd ${PN} || die
ebegin "Compiling ${PN}"
- latex ${PN}.ins extra > "${T}"/build-latex.log || die "Building style from ${PN}.ins failed"
+ rm ${PN}.sty || die
+ latex ${PN}.ins extra || die
eend
}
src_install() {
- python_optimize .
+ dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+
+ cd ${PN} || die
+
+ installation() {
if python_is_python3; then
- #python_scriptinto /usr/share/texmf-site/scripts/${PN}/
- python_newscript pythontex3.py pythontex.py
- python_newscript depythontex3.py depythontex.py
+ python_domodule {de,}${PN}3.py
else
- python_newscript pythontex2.py pythontex.py
- python_doscript pythontex_2to3.py
- python_newscript depythontex2.py depythontex.py
+ python_domodule {de,}${PN}2.py
fi
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
- python_domodule "${S}"/pythontex_engines.py "${S}"/pythontex_utils.py
-
- insinto /usr/share/texmf-site/tex/latex/pythontex/
- doins "${S}"/pythontex.sty
-
- insinto /usr/share/texmf-site/source/latex/pythontex/
- doins "${S}"/pythontex.dtx "${S}"/pythontex.ins
-
- latex-package_src_install
-
- dodoc README
- mktexlsr || die
+ latex-package_src_doinstall ${PN}.{dtx,ins,sty}
}