aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 20:09:11 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-06 20:09:11 +0100
commit0d8761a16aaa1a556fd724a1cb7ada300762401a (patch)
tree7cfa9b11628dd32f75d9624a67c5004c96343c41 /dev-tex/pythontex
parentdev-python/astropy: Switch from git-2 to git-r3 (diff)
downloadsci-0d8761a16aaa1a556fd724a1cb7ada300762401a.tar.gz
sci-0d8761a16aaa1a556fd724a1cb7ada300762401a.tar.bz2
sci-0d8761a16aaa1a556fd724a1cb7ada300762401a.zip
dev-tex/pythontex: Switch from git-2 to git-r3
Package-Manager: portage-2.2.8
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/ChangeLog8
-rw-r--r--dev-tex/pythontex/metadata.xml8
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild24
-rw-r--r--dev-tex/pythontex/pythontex-9999.ebuild33
4 files changed, 45 insertions, 28 deletions
diff --git a/dev-tex/pythontex/ChangeLog b/dev-tex/pythontex/ChangeLog
new file mode 100644
index 000000000..c0fb531e3
--- /dev/null
+++ b/dev-tex/pythontex/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-tex/pythontex
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> pythontex-0.12.ebuild,
+ pythontex-9999.ebuild, +metadata.xml:
+ Switch from git-2 to git-r3
+
diff --git a/dev-tex/pythontex/metadata.xml b/dev-tex/pythontex/metadata.xml
new file mode 100644
index 000000000..1087ec907
--- /dev/null
+++ b/dev-tex/pythontex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <use>
+ <flag name="highlighting">PLEASE FIX MY DESCRIPTION</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index 0ff97a1b9..6d50f2f78 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2-r1.ebuild,v 1.18 2012/05/09 17:16:08 aballier Exp $
@@ -17,9 +17,10 @@ LICENSE="LPPL-1.3 BSD"
KEYWORDS="~amd64"
IUSE="highlighting"
-DEPEND="app-text/texlive
- ${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND="${PYTHON_DEPS}
+ app-text/texlive"
RDEPEND="${DEPEND}
dev-texlive/texlive-xetex
>=dev-python/matplotlib-1.2.0[${PYTHON_USEDEP}]
@@ -34,7 +35,7 @@ src_prepare() {
src_compile() {
ebegin "Compiling ${PN}"
- latex ${PN}.ins extra >${T}/build-latex.log || die "Building style from ${PN}.ins failed"
+ latex ${PN}.ins extra > "${T}"/build-latex.log || die "Building style from ${PN}.ins failed"
eend
sed -i -e '1i#!/usr/bin/env python' depythontex2.py || die "adding shebang failed!"
sed -i -e '1i#!/usr/bin/env python' depythontex3.py || die "adding shebang failed!"
@@ -42,24 +43,25 @@ src_compile() {
src_install() {
python_optimize .
- if python_is_python3; then
- python_newscript pythontex3.py pythontex.py
+ if python_is_python3; then
+ python_newscript pythontex3.py pythontex.py
python_newscript depythontex3.py depythontex.py
- else python_newscript pythontex2.py pythontex.py
+ else
+ python_newscript pythontex2.py pythontex.py
python_doscript pythontex_2to3.py
python_newscript depythontex2.py depythontex.py
fi
-
+
python_export PYTHON_SCRIPTDIR
- echo ${PYTHON_SCRIPTDIR}
- python_moduleinto ${PYTHON_SCRIPTDIR} # it looks for modules here, submitted a patch for future versions.
+
+ python_moduleinto ${PYTHON_SCRIPTDIR}
python_domodule "${S}"/pythontex_engines.py "${S}"/pythontex_utils.py
insinto /usr/share/texmf-site/tex/latex/pythontex/
doins "${S}"/pythontex.sty
insinto /usr/share/texmf-site/source/latex/pythontex/
- doins "${S}"/pythontex.dtx "${S}"/pythontex.ins
+ doins "${S}"/pythontex.dtx "${S}"/pythontex.ins
latex-package_src_install
diff --git a/dev-tex/pythontex/pythontex-9999.ebuild b/dev-tex/pythontex/pythontex-9999.ebuild
index 67c1a5d0a..7ac96aad9 100644
--- a/dev-tex/pythontex/pythontex-9999.ebuild
+++ b/dev-tex/pythontex/pythontex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2-r1.ebuild,v 1.18 2012/05/09 17:16:08 aballier Exp $
@@ -6,23 +6,22 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-inherit latex-package python-single-r1 git-2
+inherit latex-package python-single-r1 git-r3
DESCRIPTION="Fast Access to Python from within LaTeX"
HOMEPAGE="https://github.com/gpoore/pythontex"
-EGIT_REPO_URI="https://github.com/gpoore/pythontex.git"
SRC_URI=""
-
+EGIT_REPO_URI="https://github.com/gpoore/pythontex.git"
SLOT="0"
LICENSE="LPPL-1.3 BSD"
KEYWORDS=""
IUSE="highlighting"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="app-text/texlive
- ${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND="${PYTHON_DEPS}
+ app-text/texlive"
RDEPEND="${DEPEND}
dev-texlive/texlive-xetex
>=dev-python/matplotlib-1.2.0[${PYTHON_USEDEP}]
@@ -30,38 +29,38 @@ RDEPEND="${DEPEND}
src_prepare() {
S="${WORKDIR}/${P}/${PN}"
- cd ${S}
+ cd "${S}" || die
rm pythontex.sty || die "Could not remove pre-compiled pythontex.sty!"
}
src_compile() {
- pwd
ebegin "Compiling ${PN}"
- latex ${PN}.ins extra >${T}/build-latex.log || die "Building style from ${PN}.ins failed"
+ latex ${PN}.ins extra > "${T}"/build-latex.log || die "Building style from ${PN}.ins failed"
eend
}
src_install() {
python_optimize .
- if python_is_python3; then
+ if python_is_python3; then
#python_scriptinto /usr/share/texmf-site/scripts/${PN}/
- python_newscript pythontex3.py pythontex.py
+ python_newscript pythontex3.py pythontex.py
python_newscript depythontex3.py depythontex.py
- else python_newscript pythontex2.py pythontex.py
+ else
+ python_newscript pythontex2.py pythontex.py
python_doscript pythontex_2to3.py
python_newscript depythontex2.py depythontex.py
fi
-
+
python_domodule "${S}"/pythontex_engines.py "${S}"/pythontex_utils.py
insinto /usr/share/texmf-site/tex/latex/pythontex/
doins "${S}"/pythontex.sty
-
+
insinto /usr/share/texmf-site/source/latex/pythontex/
- doins "${S}"/pythontex.dtx "${S}"/pythontex.ins
+ doins "${S}"/pythontex.dtx "${S}"/pythontex.ins
latex-package_src_install
dodoc README
- mktexlsr
+ mktexlsr || die
}