aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-07 01:18:00 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-07 01:18:00 +0200
commitc6df5b1f127da5c52ee53461e092dec573ff9b5d (patch)
tree8bf482a4e32496106508005f41c38710e5f4f3e7 /dev-tex
parenthopefully installing everything into the right dir now (diff)
downloadsci-c6df5b1f127da5c52ee53461e092dec573ff9b5d.tar.gz
sci-c6df5b1f127da5c52ee53461e092dec573ff9b5d.tar.bz2
sci-c6df5b1f127da5c52ee53461e092dec573ff9b5d.zip
rectified paths, added environment variable file
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index 628d2053a..fa59ae98a 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -41,28 +41,31 @@ src_compile() {
src_install() {
python_optimize .
if python_is_python3; then
+ python_scriptinto /usr/share/texmf-site/scripts/pythontex/
python_newscript pythontex3.py pythontex.py
python_newscript depythontex3.py depythontex.py
- python_scriptinto /usr/share/texmf-site/scripts/pythontex/
fi
- if ! python_is_python3; then
+ if ! python_is_python3; then
+ python_scriptinto /usr/share/texmf-site/scripts/pythontex/
python_newscript pythontex2.py pythontex.py
python_doscript pythontex_2to3.py
python_newscript depythontex2.py depythontex.py
- python_scriptinto /usr/share/texmf-site/scripts/pythontex/
fi
- doins pythontex_engines.py pythontex_utils.py
insinto /usr/share/texmf-site/scripts/pythontex/
-
+ doins pythontex_engines.py pythontex_utils.py
+
+ insinto /usr/share/texmf-site/tex/latex/pythontex/
doins pythontex.sty
- insinto /tex/latex/pythontex/
- doins pythontex.dtx pythontex.ins
- insinto /source/latex/pythontex/
-
+ insinto /usr/share/texmf-site/source/latex/pythontex/
+ doins pythontex.dtx pythontex.ins
+
latex-package_src_install
+
+ echo "LDPATH=/usr/share/texmf-site/scripts/pythontex/" >> "${T}"/99${PN} || die "Can't write environment variable."
+ doenvd "${T}"/99${PN}
dodoc README