aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-05 22:41:55 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-05 22:41:55 +0200
commitb3fec6c686f1ce72b717b8ed10021e266096bf5f (patch)
tree537d40fef23ad265d4181742a8d92cbc734ea114 /dev-tex
parentRemoved doind *.cfg call (diff)
downloadsci-b3fec6c686f1ce72b717b8ed10021e266096bf5f.tar.gz
sci-b3fec6c686f1ce72b717b8ed10021e266096bf5f.tar.bz2
sci-b3fec6c686f1ce72b717b8ed10021e266096bf5f.zip
assed shebang fix an python optimize
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index fb5da2dcf..76d451f9f 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -26,13 +26,14 @@ RDEPEND="${DEPEND}
TEXMF=/usr/share/texmf-site
src_prepare() {
- pwd
rm pythontex.sty
}
src_compile() {
ebegin "Compiling ${PN}"
- latex ${PN}.ins || die
+ python_optimize .
+ python_fix_shebang .
+ latex ${PN}.ins extra >/dev/null || die "Building style from ${PN}.ins failed"
eend
}