aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-03-04 10:25:20 +0100
committerChristoph Junghans <ottxor@gentoo.org>2015-03-06 11:15:38 -0700
commit3e1fb117de51abc3dc7e383d512646acca9e45ac (patch)
tree8e997187b25d1b1ab2e43588d8f231e7c5b37077 /dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
parentversion bump (diff)
downloadsci-3e1fb117de51abc3dc7e383d512646acca9e45ac.tar.gz
sci-3e1fb117de51abc3dc7e383d512646acca9e45ac.tar.bz2
sci-3e1fb117de51abc3dc7e383d512646acca9e45ac.zip
dev-util/VampirTrace: Version bump
Package-Manager: portage-2.2.14
Diffstat (limited to 'dev-util/VampirTrace/VampirTrace-5.14.4.ebuild')
-rw-r--r--dev-util/VampirTrace/VampirTrace-5.14.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild b/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
new file mode 100644
index 000000000..5ff44d14f
--- /dev/null
+++ b/dev-util/VampirTrace/VampirTrace-5.14.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils cuda
+
+MY_PV="${PV}-gpu2"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An open source library that allows detailed logging of program execution for parallel applications"
+HOMEPAGE="http://tu-dresden.de/die_tu_dresden/zentrale_einrichtungen/zih/forschung/projekte/vampirtrace/accelerator"
+SRC_URI="http://wwwpub.zih.tu-dresden.de/~mlieber/dcount/dcount.php?package=gputrace&get=${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="vampir"
+KEYWORDS="~amd64"
+IUSE="cuda"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="
+ virtual/mpi
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.0.0 )"
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ econf $(use_with cuda cuda-dir "${EPREFIX}"/opt/cuda)
+}
+
+src_install() {
+ default
+ # avoid collisions with app-text/lcdf-typetools:
+ mv "${D}/usr/bin/otfinfo" "${D}/usr/bin/otfinfo.vampir" || die
+ if [ -e "${D}/usr/lib/debug/usr/bin/otfinfo.debug" ]; then
+ mv "${D}/usr/lib/debug/usr/bin/otfinfo.debug" "${D}/usr/lib/debug/usr/bin/otfinfo.vampir.debug" || die
+ fi
+ # libtool is already installed:
+ rm "${D}/usr/share/libtool" || die
+}